summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-25 00:58:19 +0000
committerSam James <sam@gentoo.org>2022-01-25 00:58:19 +0000
commita674576191fa3649c7d008202f3c6af71768af70 (patch)
tree661a5a58d2899b0d4f6672cd31cf9b3024b9d18d /games-board/gnome-mahjongg
parentmedia-gfx/frogr: fix build with meson 0.61 (diff)
downloadgentoo-a674576191fa3649c7d008202f3c6af71768af70.tar.gz
gentoo-a674576191fa3649c7d008202f3c6af71768af70.tar.bz2
gentoo-a674576191fa3649c7d008202f3c6af71768af70.zip
games-board/gnome-mahjongg: fix build with meson 0.61
Closes: https://bugs.gentoo.org/831466 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-board/gnome-mahjongg')
-rw-r--r--games-board/gnome-mahjongg/files/gnome-mahjongg-3.38.3-meson-0.61.patch32
-rw-r--r--games-board/gnome-mahjongg/gnome-mahjongg-3.38.3.ebuild6
2 files changed, 37 insertions, 1 deletions
diff --git a/games-board/gnome-mahjongg/files/gnome-mahjongg-3.38.3-meson-0.61.patch b/games-board/gnome-mahjongg/files/gnome-mahjongg-3.38.3-meson-0.61.patch
new file mode 100644
index 000000000000..9b9f26d09f95
--- /dev/null
+++ b/games-board/gnome-mahjongg/files/gnome-mahjongg-3.38.3-meson-0.61.patch
@@ -0,0 +1,32 @@
+https://gitlab.gnome.org/GNOME/gnome-mahjongg/-/merge_requests/26
+https://bugs.gentoo.org/831466
+
+From 7604f8c8311f1088293596e639fefafdbeb73235 Mon Sep 17 00:00:00 2001
+From: Jan Beich <jbeich@FreeBSD.org>
+Date: Mon, 24 Jan 2022 11:22:48 +0000
+Subject: [PATCH] meson: drop unused argument for i18n.merge_file()
+
+Ignored in Meson < 0.60.0, deprecated since 0.60.1 and fatal since 0.61.0.
+
+data/meson.build:24:0: ERROR: Function does not take positional arguments.
+data/meson.build:45:0: ERROR: Function does not take positional arguments.
+--- a/data/meson.build
++++ b/data/meson.build
+@@ -22,7 +22,6 @@ install_data ('smooth.png', install_dir: join_paths (pkgdatadir, 'themes'))
+ install_data ('edu_kang_xi.png', install_dir: join_paths (pkgdatadir, 'themes'))
+
+ desktop_file = i18n.merge_file (
+- 'desktop-file',
+ input: 'org.gnome.Mahjongg.desktop.in',
+ output: 'org.gnome.Mahjongg.desktop',
+ install: true,
+@@ -42,7 +41,7 @@ if desktop_file_validate.found()
+ )
+ endif
+
+-appdata_file = i18n.merge_file ('appdata-file',
++appdata_file = i18n.merge_file (
+ input: 'org.gnome.Mahjongg.appdata.xml.in',
+ output: 'org.gnome.Mahjongg.appdata.xml',
+ install: true,
+GitLab
diff --git a/games-board/gnome-mahjongg/gnome-mahjongg-3.38.3.ebuild b/games-board/gnome-mahjongg/gnome-mahjongg-3.38.3.ebuild
index b6a00c10a6e5..d7c2f9a1096b 100644
--- a/games-board/gnome-mahjongg/gnome-mahjongg-3.38.3.ebuild
+++ b/games-board/gnome-mahjongg/gnome-mahjongg-3.38.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -30,6 +30,10 @@ BDEPEND="
virtual/pkgconfig
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.38.3-meson-0.61.patch
+)
+
src_prepare() {
xdg_src_prepare
vala_src_prepare