summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-09-07 15:52:04 -0500
committerAustin English <wizardedit@gentoo.org>2016-09-07 17:16:14 -0500
commit4b6f3f8dfb070c5642e0e6c4e6c0cb61162f4176 (patch)
tree2a610208b3d794258f2effea46b6b0dd97244456 /games-board/gnono
parentgames-board/gnubg: remove deprecated games eclass (diff)
downloadgentoo-4b6f3f8dfb070c5642e0e6c4e6c0cb61162f4176.tar.gz
gentoo-4b6f3f8dfb070c5642e0e6c4e6c0cb61162f4176.tar.bz2
gentoo-4b6f3f8dfb070c5642e0e6c4e6c0cb61162f4176.zip
games-board/gnono: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
Diffstat (limited to 'games-board/gnono')
-rw-r--r--games-board/gnono/gnono-1.9.1-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/games-board/gnono/gnono-1.9.1-r1.ebuild b/games-board/gnono/gnono-1.9.1-r1.ebuild
new file mode 100644
index 000000000000..c2c9c9c21762
--- /dev/null
+++ b/games-board/gnono/gnono-1.9.1-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools eutils gnome2-utils
+
+DESCRIPTION="A rewrite for GNOME of the Windows card game WUNO"
+HOMEPAGE="https://sourceforge.net/projects/gnono/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="gnome-base/libgnomeui
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-glib-single-include.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}