summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-10-23 11:10:31 -0400
committerMichael Sterrett <mr_bones_@gentoo.org>2015-10-23 11:10:44 -0400
commit6bc7eceb6efa29fc146bcca13164bc5f7ce665b3 (patch)
tree2ee762996a776d481966eb9bb95ca5823f30764b /games-board/gnuchess/gnuchess-6.2.2-r1.ebuild
parentnet-libs/libmediawiki: use correct version (diff)
downloadgentoo-6bc7eceb6efa29fc146bcca13164bc5f7ce665b3.tar.gz
gentoo-6bc7eceb6efa29fc146bcca13164bc5f7ce665b3.tar.bz2
gentoo-6bc7eceb6efa29fc146bcca13164bc5f7ce665b3.zip
apply upstream patch for --addbook option to fix bug #563864
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'games-board/gnuchess/gnuchess-6.2.2-r1.ebuild')
-rw-r--r--games-board/gnuchess/gnuchess-6.2.2-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/games-board/gnuchess/gnuchess-6.2.2-r1.ebuild b/games-board/gnuchess/gnuchess-6.2.2-r1.ebuild
new file mode 100644
index 000000000000..484ec1274266
--- /dev/null
+++ b/games-board/gnuchess/gnuchess-6.2.2-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit flag-o-matic games
+
+DESCRIPTION="Console based chess interface"
+HOMEPAGE="https://www.gnu.org/software/chess/chess.html"
+SRC_URI="mirror://gnu/chess/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+PATCHES=( "${FILESDIR}"/${P}-addbook.patch )
+
+src_configure() {
+ strip-flags # bug #199097
+ egamesconf --without-readline # bug 491088
+}
+
+src_install () {
+ default
+ prepgamesdirs
+}