summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-06-23 14:11:11 +0200
committerDavid Seifert <soap@gentoo.org>2020-06-23 14:11:11 +0200
commit256cdc38b4e61f806b17ca67bd2d8fc9e659164b (patch)
treeebc8f4faa92b51498c16923cf0ac6f7fb0ce37af /games-board/gnugo
parentgames-board/gnugo: Remove old (diff)
downloadgentoo-256cdc38b4e61f806b17ca67bd2d8fc9e659164b.tar.gz
gentoo-256cdc38b4e61f806b17ca67bd2d8fc9e659164b.tar.bz2
gentoo-256cdc38b4e61f806b17ca67bd2d8fc9e659164b.zip
games-board/gnugo: [QA] Call AM_PROG_AR
Closes: https://bugs.gentoo.org/720786 Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'games-board/gnugo')
-rw-r--r--games-board/gnugo/files/gnugo-3.9.1-autotools.patch10
-rw-r--r--games-board/gnugo/gnugo-3.9.1-r2.ebuild16
2 files changed, 22 insertions, 4 deletions
diff --git a/games-board/gnugo/files/gnugo-3.9.1-autotools.patch b/games-board/gnugo/files/gnugo-3.9.1-autotools.patch
new file mode 100644
index 000000000000..79e28fa9b7bf
--- /dev/null
+++ b/games-board/gnugo/files/gnugo-3.9.1-autotools.patch
@@ -0,0 +1,10 @@
+--- a/configure.in
++++ b/configure.in
+@@ -151,6 +151,7 @@
+
+ AC_PROG_CPP
+ AC_PROG_RANLIB
++AM_PROG_AR
+
+ dnl required since we use SUBDIRS in Makefile.am
+ AC_PROG_MAKE_SET
diff --git a/games-board/gnugo/gnugo-3.9.1-r2.ebuild b/games-board/gnugo/gnugo-3.9.1-r2.ebuild
index cfcbcca0fbbb..0bafb2715fdf 100644
--- a/games-board/gnugo/gnugo-3.9.1-r2.ebuild
+++ b/games-board/gnugo/gnugo-3.9.1-r2.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
+inherit autotools
DESCRIPTION="A Go-playing program"
HOMEPAGE="https://www.gnu.org/software/gnugo/devel.html"
@@ -14,15 +16,21 @@ IUSE="readline"
RDEPEND="
readline? ( sys-libs/readline:0= )
- >=sys-libs/ncurses-5.2-r3:0=
-"
+ >=sys-libs/ncurses-5.2-r3:0="
DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}"/${P}-invalid-move.patch
"${FILESDIR}"/${P}-format-security.patch
+ "${FILESDIR}"/${P}-autotools.patch
)
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
src_configure() {
econf \
$(use_with readline) \