summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-board/gnugo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-board/gnugo')
-rw-r--r--games-board/gnugo/Manifest1
-rw-r--r--games-board/gnugo/files/gnugo-3.9.1-invalid-move.patch21
-rw-r--r--games-board/gnugo/gnugo-3.9.1-r1.ebuild34
-rw-r--r--games-board/gnugo/metadata.xml5
4 files changed, 61 insertions, 0 deletions
diff --git a/games-board/gnugo/Manifest b/games-board/gnugo/Manifest
new file mode 100644
index 000000000000..6bf7021caaec
--- /dev/null
+++ b/games-board/gnugo/Manifest
@@ -0,0 +1 @@
+DIST gnugo-3.9.1.tar.gz 3207748 SHA256 b80bde5b31bf1e90f78ffc11f49c65ee866bf007ea3f210ce1ce652cd5484794 SHA512 b2b215fb8c1ebb0b58e54d14dcc02af3b76bde3a1b84a842a11a0a6018c77a2464c44b26fe0e7ad73b2b2e7fa22005466821bf762108c2c2e04428d3d459af97 WHIRLPOOL e3d398ca8d500a96d4e06e406d3e1c0375bc8641ef052260512c3181db3d74901e571ec1aaddfb96ba4fd635d1e6801fec4f7ddf563a199b50e609e1befe2d4e
diff --git a/games-board/gnugo/files/gnugo-3.9.1-invalid-move.patch b/games-board/gnugo/files/gnugo-3.9.1-invalid-move.patch
new file mode 100644
index 000000000000..fc8fd8f524db
--- /dev/null
+++ b/games-board/gnugo/files/gnugo-3.9.1-invalid-move.patch
@@ -0,0 +1,21 @@
+From 84a32e9cee2a70c0ec6ef58c1be279fed84a9a53 Mon Sep 17 00:00:00 2001
+From: Gunnar Farnebäck <gunnar@lysator.liu.se>
+Date: Thu, 13 Jun 2013 18:45:03 +0000
+Subject: Avoid crashing due to registering an invalid loss move reason.
+
+---
+diff --git a/engine/value_moves.c b/engine/value_moves.c
+index e9f2daa..7ec8fdd 100644
+--- a/engine/value_moves.c
++++ b/engine/value_moves.c
+@@ -383,7 +383,7 @@ do_find_more_owl_attack_and_defense_moves(int color, int pos,
+ int dcode = owl_does_defend(pos, dd, &kworm);
+
+ if (dcode >= DRAGON2(dd).owl_defense_code) {
+- if (dcode == LOSS)
++ if (dcode == LOSS && kworm != NO_MOVE)
+ add_loss_move(pos, dd, kworm);
+ else
+ add_owl_defense_move(pos, dd, dcode);
+--
+cgit v0.9.0.2
diff --git a/games-board/gnugo/gnugo-3.9.1-r1.ebuild b/games-board/gnugo/gnugo-3.9.1-r1.ebuild
new file mode 100644
index 000000000000..10ef21944321
--- /dev/null
+++ b/games-board/gnugo/gnugo-3.9.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="A Go-playing program"
+HOMEPAGE="http://www.gnu.org/software/gnugo/devel.html"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="readline"
+
+DEPEND="readline? ( sys-libs/readline:0 )
+ >=sys-libs/ncurses-5.2-r3"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-invalid-move.patch
+}
+
+src_configure() {
+ egamesconf \
+ $(use_with readline) \
+ --enable-cache-size=32
+}
+
+src_install() {
+ default
+ prepgamesdirs
+}
diff --git a/games-board/gnugo/metadata.xml b/games-board/gnugo/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-board/gnugo/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>