summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-09-14 11:28:41 +0300
committerMart Raudsepp <leio@gentoo.org>2018-09-14 11:33:47 +0300
commit6bbb0b30b8f398a38d92be329ee4df94b95c5efd (patch)
treec065892acaa95339062fda686866f69fca33e75b /games-board/iagno/iagno-3.30.0.ebuild
parentdev-libs/yajl-2.1.0-r1: alpha stable (diff)
downloadgentoo-6bbb0b30b8f398a38d92be329ee4df94b95c5efd.tar.gz
gentoo-6bbb0b30b8f398a38d92be329ee4df94b95c5efd.tar.bz2
gentoo-6bbb0b30b8f398a38d92be329ee4df94b95c5efd.zip
games-board/iagno: bump to 3.30.0
* Remove unnecessary vala dep - this project is still using autotools and shipping pregenerated C files, thus valac is not used other than check for presence. * Downgrade yelp-tools dep to itstool - yelp-tools is a developer-only package, so at most we'd need it with eautoreconf, if even that. * Adapt to upstream porting from intltool to newer gettext. * Add missing libxml2:2 build dep for gresource files xml-stripblanks usage, for which xmllint is used by glib-compile-resources. Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'games-board/iagno/iagno-3.30.0.ebuild')
-rw-r--r--games-board/iagno/iagno-3.30.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/games-board/iagno/iagno-3.30.0.ebuild b/games-board/iagno/iagno-3.30.0.ebuild
new file mode 100644
index 000000000000..1a42da387eae
--- /dev/null
+++ b/games-board/iagno/iagno-3.30.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2
+
+DESCRIPTION="Dominate the board in a classic version of Reversi"
+HOMEPAGE="https://wiki.gnome.org/Apps/Iagno"
+
+LICENSE="GPL-3+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.40:2
+ >=gnome-base/librsvg-2.32.0:2
+ >=media-libs/libcanberra-0.26[gtk3]
+ >=x11-libs/gtk+-3.15:3
+"
+RDEPEND="${COMMON_DEPEND}
+ !<x11-themes/gnome-themes-standard-3.14
+"
+# libxml2:2 needed for glib-compile-resources xml-stripblanks attributes
+DEPEND="${COMMON_DEPEND}
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure VALAC="$(type -P true)"
+}