summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-board/megamek
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-board/megamek')
-rw-r--r--games-board/megamek/Manifest1
-rw-r--r--games-board/megamek/megamek-0.34.10.ebuild51
-rw-r--r--games-board/megamek/metadata.xml8
3 files changed, 60 insertions, 0 deletions
diff --git a/games-board/megamek/Manifest b/games-board/megamek/Manifest
new file mode 100644
index 000000000000..6f6b4394e72c
--- /dev/null
+++ b/games-board/megamek/Manifest
@@ -0,0 +1 @@
+DIST MegaMek-v0.34.10.zip 16677286 SHA256 14aaf88908798c784f47f75465a52bff9ff8c9cf261476d1ef6ef8a50303865c SHA512 943f6ed4f4d57197092a7aa09637f60827f23181a7b8b0991907fcc62109b471ea2ce53816a79dfcad9d8da65c9514be3190e924d9bf2b17aacf84fc1fa6e037 WHIRLPOOL 10d5c2066784c7722c99db1a192358554bd68979272a58f12849028902aaad3f23ca0024559c73e7966b2e441a54a1df9f159ad14f94679c60c3379bcc3aec5e
diff --git a/games-board/megamek/megamek-0.34.10.ebuild b/games-board/megamek/megamek-0.34.10.ebuild
new file mode 100644
index 000000000000..a695a34a8db5
--- /dev/null
+++ b/games-board/megamek/megamek-0.34.10.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils java-pkg-2 java-ant-2 games
+
+DESCRIPTION="an unofficial, online version of the Classic BattleTech board game"
+HOMEPAGE="http://megamek.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/MegaMek-v${PV}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.5
+ app-arch/unzip"
+RDEPEND=">=virtual/jre-1.5"
+
+S=${WORKDIR}
+
+pkg_setup() {
+ games_pkg_setup
+ java-pkg-2_pkg_setup
+}
+
+src_prepare() {
+ rm -v *.jar || die
+ edos2unix startup.sh
+ sed -i \
+ -e "s:XmX:Xmx:" \
+ -e "s:/usr/share/java:${GAMES_DATADIR}/${PN}:" \
+ -e "s:/usr/share/MegaMek:${GAMES_DATADIR}/${PN}:" \
+ startup.sh || die "sed failed"
+ java-pkg-2_src_prepare
+}
+
+src_compile() {
+ eant
+}
+
+src_install() {
+ newgamesbin startup.sh ${PN}
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r data docs l10n lib mmconf *.jar readme*
+ dodoc HACKING readme.txt
+ make_desktop_entry ${PN} MegaMek /usr/share/pixmaps/${PN}.gif
+ newicon data/images/misc/megamek-icon.gif ${PN}.gif
+ prepgamesdirs
+}
diff --git a/games-board/megamek/metadata.xml b/games-board/megamek/metadata.xml
new file mode 100644
index 000000000000..34598d2fac55
--- /dev/null
+++ b/games-board/megamek/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">megamek</remote-id>
+ </upstream>
+</pkgmetadata>