summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <steils@gentoo.org>2019-08-18 01:28:01 +0300
committerStefan Strogin <steils@gentoo.org>2019-08-18 01:28:01 +0300
commit97cf190347516fc2563e4ff2677b85361d165157 (patch)
tree1419deb05de929e3783f5ed206a89b4aba2d8fd9 /games-board/mt_ncurses_client/mt_ncurses_client-0.1.98-r1.ebuild
parentgames-arcade/ninvaders: fix building with ncurses[tinfo] (diff)
downloadgentoo-97cf190347516fc2563e4ff2677b85361d165157.tar.gz
gentoo-97cf190347516fc2563e4ff2677b85361d165157.tar.bz2
gentoo-97cf190347516fc2563e4ff2677b85361d165157.zip
games-board/mt_ncurses_client: fix building with ncurses[tinfo]
Closes: https://bugs.gentoo.org/691016 Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Stefan Strogin <steils@gentoo.org>
Diffstat (limited to 'games-board/mt_ncurses_client/mt_ncurses_client-0.1.98-r1.ebuild')
-rw-r--r--games-board/mt_ncurses_client/mt_ncurses_client-0.1.98-r1.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/games-board/mt_ncurses_client/mt_ncurses_client-0.1.98-r1.ebuild b/games-board/mt_ncurses_client/mt_ncurses_client-0.1.98-r1.ebuild
index cd247d29f412..f2228134f6dd 100644
--- a/games-board/mt_ncurses_client/mt_ncurses_client-0.1.98-r1.ebuild
+++ b/games-board/mt_ncurses_client/mt_ncurses_client-0.1.98-r1.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+inherit toolchain-funcs
+
DESCRIPTION="client for the french tarot game maitretarot"
HOMEPAGE="http://www.nongnu.org/maitretarot/"
SRC_URI="https://savannah.nongnu.org/download/maitretarot/${PN}.pkg/${PV}/${P}.tar.bz2"
@@ -22,3 +24,8 @@ RDEPEND=${DEPEND}
PATCHES=(
"${FILESDIR}"/${P}-format.patch
)
+
+src_configure() {
+ export LIBS="$( $(tc-getPKG_CONFIG) --libs ncurses )"
+ default
+}