summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-board/pasang-emas/pasang-emas-3.1.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-board/pasang-emas/pasang-emas-3.1.0.ebuild')
-rw-r--r--games-board/pasang-emas/pasang-emas-3.1.0.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/games-board/pasang-emas/pasang-emas-3.1.0.ebuild b/games-board/pasang-emas/pasang-emas-3.1.0.ebuild
new file mode 100644
index 000000000000..6684951c6610
--- /dev/null
+++ b/games-board/pasang-emas/pasang-emas-3.1.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils gnome2-utils games
+
+DESCRIPTION="A traditional game of Brunei"
+HOMEPAGE="http://pasang-emas.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
+ extras? ( mirror://sourceforge/${PN}/pasang-emas-themes-1.0.tar.bz2
+ mirror://sourceforge/${PN}/pet-marble.tar.bz2
+ mirror://sourceforge/${PN}/pet-fragrance.tar.bz2 )"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="extras nls"
+
+RDEPEND="app-text/gnome-doc-utils
+ >=x11-libs/gtk+-2.18.2:2
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ app-text/rarian
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+ sed -i \
+ -e '/Encoding/d' \
+ -e '/Icon/s:\.png::' \
+ data/pasang-emas.desktop.in || die
+ gnome2_omf_fix
+}
+
+src_configure() {
+ egamesconf \
+ --localedir=/usr/share/locale \
+ --with-omf-dir=/usr/share/omf \
+ --with-help-dir=/usr/share/gnome/help \
+ $(use_enable nls)
+}
+
+src_install() {
+ default
+ if use extras; then
+ insinto "${GAMES_DATADIR}/${PN}"/themes
+ doins -r \
+ "${WORKDIR}"/marble \
+ "${WORKDIR}"/pasang-emas-themes-1.0/{conteng,kaca} \
+ "${WORKDIR}"/fragrance
+ fi
+ use nls || rm -rf "${D}"usr/share/locale
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_scrollkeeper_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_scrollkeeper_update
+}
+
+pkg_postrm() {
+ gnome2_scrollkeeper_update
+}