summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-05-21 21:20:50 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-05-21 21:21:31 +0200
commit87eca01a019c71627d031f61a5257c4a5c3a6cee (patch)
tree068c952188e3d7d8023869281bc2d4b26e1c3773 /games-board/peg-e/peg-e-1.2.8.ebuild
parentgames-board/simsu: Drop 1.3.6 (diff)
downloadgentoo-87eca01a019c71627d031f61a5257c4a5c3a6cee.tar.gz
gentoo-87eca01a019c71627d031f61a5257c4a5c3a6cee.tar.bz2
gentoo-87eca01a019c71627d031f61a5257c4a5c3a6cee.zip
games-board/peg-e: 1.2.8 version bump
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'games-board/peg-e/peg-e-1.2.8.ebuild')
-rw-r--r--games-board/peg-e/peg-e-1.2.8.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/games-board/peg-e/peg-e-1.2.8.ebuild b/games-board/peg-e/peg-e-1.2.8.ebuild
new file mode 100644
index 000000000000..40086cd07d19
--- /dev/null
+++ b/games-board/peg-e/peg-e-1.2.8.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop qmake-utils xdg-utils
+
+DESCRIPTION="A peg solitaire game"
+HOMEPAGE="https://gottcode.org/peg-e/"
+SRC_URI="https://gottcode.org/peg-e/${P}-src.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.2.5-gentoo.patch )
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}