summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-08-02 11:29:13 -0500
committerAustin English <wizardedit@gentoo.org>2016-08-02 11:59:46 -0500
commitbd1b38ce1ae733b50c20634d635add083ff5d58e (patch)
tree1851fae0ebfe1270dfd14341719133951254383c /games-board/qcheckers
parentdev-python/nnpy: version bump to 1.2 (diff)
downloadgentoo-bd1b38ce1ae733b50c20634d635add083ff5d58e.tar.gz
gentoo-bd1b38ce1ae733b50c20634d635add083ff5d58e.tar.bz2
gentoo-bd1b38ce1ae733b50c20634d635add083ff5d58e.zip
games-board/qcheckers: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
Diffstat (limited to 'games-board/qcheckers')
-rw-r--r--games-board/qcheckers/qcheckers-20091230-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/games-board/qcheckers/qcheckers-20091230-r1.ebuild b/games-board/qcheckers/qcheckers-20091230-r1.ebuild
new file mode 100644
index 000000000000..df73d29494af
--- /dev/null
+++ b/games-board/qcheckers/qcheckers-20091230-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils qmake-utils
+
+MY_PN=${PN/qc/QC}
+
+DESCRIPTION="Qt4 based checkers game"
+HOMEPAGE="https://code.google.com/p/qcheckers/"
+SRC_URI="https://qcheckers.googlecode.com/files/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-qt/qtgui:4"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${MY_PN}
+
+src_configure() {
+ eqmake4 ${MY_PN}.pro
+}
+
+src_install() {
+ dobin ${MY_PN}
+ newicon icons/help-about.png ${PN}.png
+ make_desktop_entry ${MY_PN} ${MY_PN}
+ dodoc README
+}