summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-board/spider
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-board/spider')
-rw-r--r--games-board/spider/Manifest2
-rw-r--r--games-board/spider/metadata.xml8
-rw-r--r--games-board/spider/spider-1.2_p4-r1.ebuild85
3 files changed, 95 insertions, 0 deletions
diff --git a/games-board/spider/Manifest b/games-board/spider/Manifest
new file mode 100644
index 000000000000..efca0d60764d
--- /dev/null
+++ b/games-board/spider/Manifest
@@ -0,0 +1,2 @@
+DIST spider_1.2-4.diff.gz 2882 SHA256 d4135ae12f39a1f8aa4286fda607e61751d4c5898d22b962e62bc2f73bc71bbd SHA512 e1e6eb4d5b14de7c32e1537877a3d26470c032bea567aa679c8a3744d62ab6b12d81bf05120679a273d98b6fd976c32d24ce9c54b720d006c51464f7ff6d5e75 WHIRLPOOL f0932d0f3abbfd93240d05b739addd49b5c0d4e0d9cec7ec65149e088494c29698e0737db4a895347722ca9ac7bb4427a3276e91e5237fdd3aacaeed8590dd25
+DIST spider_1.2.orig.tar.gz 168209 SHA256 0c5a813a967b9f5ca8c799c05b2583481a292fbcca57293055c243566a7f03b3 SHA512 a1d01f15ca37c8abdcc9f7c3dac925b1726f9b58ce51eb4096a9248abe0a55086ccdd5cc5ec358c2ee609ff089978676a3e3c669062a522ed7f1d4ea1ce33ab0 WHIRLPOOL bec06ca75c28416a5359022e24948c6c1e06e7f37e857f657e00b41a2bf69ee76f31061bec5734657e755134c9197d59b2ee78447c142c97cace8b65e74e09af
diff --git a/games-board/spider/metadata.xml b/games-board/spider/metadata.xml
new file mode 100644
index 000000000000..84627512f9ba
--- /dev/null
+++ b/games-board/spider/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+ <use>
+ <flag name="athena">Enable athena widgets</flag>
+ </use>
+</pkgmetadata>
diff --git a/games-board/spider/spider-1.2_p4-r1.ebuild b/games-board/spider/spider-1.2_p4-r1.ebuild
new file mode 100644
index 000000000000..58a7981b0605
--- /dev/null
+++ b/games-board/spider/spider-1.2_p4-r1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils gnome2-utils games
+
+MY_P="${P%%_*}"
+MY_P="${MY_P/-/_}"
+DEB_V="${P##*_p}"
+
+DESCRIPTION="Spider Solitaire"
+HOMEPAGE="http://packages.debian.org/stable/games/spider"
+SRC_URI="mirror://debian/pool/main/s/spider/${MY_P}.orig.tar.gz
+ mirror://debian/pool/main/s/spider/${MY_P}-${DEB_V}.diff.gz"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="athena"
+
+RDEPEND="x11-libs/libXext
+ athena? ( x11-libs/libXaw )
+ x11-libs/libXmu
+ x11-libs/libXt"
+DEPEND="${RDEPEND}
+ x11-misc/imake
+ x11-proto/xproto"
+
+S=${WORKDIR}/${MY_P/_/-}.orig
+
+src_prepare() {
+ epatch "${WORKDIR}"/${MY_P}-${DEB_V}.diff
+ sed -i \
+ -e '/MKDIRHIER/s:/X11::' \
+ *Imakefile \
+ || die "sed failed"
+ rm Makefile
+}
+
+src_configure() {
+ imake \
+ -DUseInstalled \
+ -DSmallCards=NO \
+ -DRoundCards \
+ $(use athena && echo "-DCompileXAW=YES" || echo "-DCompileXlibOnly=YES") \
+ -I/usr/lib/X11/config \
+ || die "imake failed"
+ sed -i \
+ -e '/CC = /d' \
+ -e "s/CDEBUGFLAGS = .*$/CDEBUGFLAGS = ${CFLAGS}/" \
+ -e '/LDOPTIONS = /s/$/$(LDFLAGS)/' \
+ Makefile \
+ || die "sed failed"
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ BINDIR="${GAMES_BINDIR}" \
+ MANSUFFIX="6" \
+ MANDIR="/usr/share/man/man6" \
+ HELPDIR="/usr/share/doc/${PF}" \
+ install install.doc install.man
+
+ dodoc README* ChangeLog
+ newicon icons/Spider.png ${PN}.png
+ newicon -s 32 icons/Spider32x32.png ${PN}.png
+ make_desktop_entry spider Spider
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}