summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-29 10:13:09 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-29 13:24:56 +0200
commit5c7110c65a209ca7c48d354f7ccbcadd9813812d (patch)
treef6d7ef258c2a0573f5650224cfe906736df29320 /games-board/spider
parentgames-board/spider: Stop using games.eclass (diff)
downloadgentoo-5c7110c65a209ca7c48d354f7ccbcadd9813812d.tar.gz
gentoo-5c7110c65a209ca7c48d354f7ccbcadd9813812d.tar.bz2
gentoo-5c7110c65a209ca7c48d354f7ccbcadd9813812d.zip
games-board/spider: Drop old
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-board/spider')
-rw-r--r--games-board/spider/spider-1.2_p4-r1.ebuild82
1 files changed, 0 insertions, 82 deletions
diff --git a/games-board/spider/spider-1.2_p4-r1.ebuild b/games-board/spider/spider-1.2_p4-r1.ebuild
deleted file mode 100644
index 0d2b229121cc..000000000000
--- a/games-board/spider/spider-1.2_p4-r1.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils gnome2-utils games
-
-MY_P="${P%%_*}"
-MY_P="${MY_P/-/_}"
-DEB_V="${P##*_p}"
-
-DESCRIPTION="Spider Solitaire"
-HOMEPAGE="http://packages.debian.org/stable/games/spider"
-SRC_URI="mirror://debian/pool/main/s/spider/${MY_P}.orig.tar.gz
- mirror://debian/pool/main/s/spider/${MY_P}-${DEB_V}.diff.gz"
-
-LICENSE="HPND"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="athena"
-
-RDEPEND="x11-libs/libXext
- athena? ( x11-libs/libXaw )
- x11-libs/libXmu
- x11-libs/libXt"
-DEPEND="${RDEPEND}
- x11-misc/imake
- x11-proto/xproto"
-
-S=${WORKDIR}/${MY_P/_/-}.orig
-
-src_prepare() {
- epatch "${WORKDIR}"/${MY_P}-${DEB_V}.diff
- sed -i \
- -e '/MKDIRHIER/s:/X11::' \
- *Imakefile \
- || die "sed failed"
- rm Makefile
-}
-
-src_configure() {
- xmkmf \
- -DSmallCards=NO \
- -DRoundCards \
- $(use athena && echo "-DCompileXAW=YES" || echo "-DCompileXlibOnly=YES") \
- || die "imake failed"
- sed -i \
- -e '/CC = /d' \
- -e "s/CDEBUGFLAGS = .*$/CDEBUGFLAGS = ${CFLAGS}/" \
- -e '/LDOPTIONS = /s/$/$(LDFLAGS)/' \
- Makefile \
- || die "sed failed"
-}
-
-src_install() {
- emake \
- DESTDIR="${D}" \
- BINDIR="${GAMES_BINDIR}" \
- MANSUFFIX="6" \
- MANDIR="/usr/share/man/man6" \
- HELPDIR="/usr/share/doc/${PF}" \
- install install.doc install.man
-
- dodoc README* ChangeLog
- newicon icons/Spider.png ${PN}.png
- newicon -s 32 icons/Spider32x32.png ${PN}.png
- make_desktop_entry spider Spider
- prepgamesdirs
-}
-
-pkg_preinst() {
- games_pkg_preinst
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- games_pkg_postinst
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}