summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2017-01-26 13:47:54 -0600
committerMatthias Maier <tamiko@gentoo.org>2017-01-26 13:47:54 -0600
commit17200647213345634fe3ce051e422a98a7de28c6 (patch)
treea25f37c8ff75b8fcdb02771ad293349c32c1dbd4 /games-board/stockfish/stockfish-7.ebuild
parentsci-visualization/paraview: drop old (diff)
downloadgentoo-17200647213345634fe3ce051e422a98a7de28c6.tar.gz
gentoo-17200647213345634fe3ce051e422a98a7de28c6.tar.bz2
gentoo-17200647213345634fe3ce051e422a98a7de28c6.zip
games-board/stockfish: drop old
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'games-board/stockfish/stockfish-7.ebuild')
-rw-r--r--games-board/stockfish/stockfish-7.ebuild70
1 files changed, 0 insertions, 70 deletions
diff --git a/games-board/stockfish/stockfish-7.ebuild b/games-board/stockfish/stockfish-7.ebuild
deleted file mode 100644
index ff0852b95b16..000000000000
--- a/games-board/stockfish/stockfish-7.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-inherit toolchain-funcs
-
-DESCRIPTION="Free UCI chess engine, claimed to be the strongest in the world"
-HOMEPAGE="http://stockfishchess.org/"
-
-SRC_URI="https://stockfish.s3.amazonaws.com/${P}-src.zip"
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="armv7 cpu_flags_x86_avx2 cpu_flags_x86_popcnt cpu_flags_x86_sse debug
- general-32 general-64 +optimize"
-
-DEPEND="|| ( app-arch/unzip app-arch/zip )"
-RDEPEND=""
-
-S="${WORKDIR}/${P}-src/src"
-
-src_prepare() {
- default
-
- # prevent pre-stripping
- sed -e 's:-strip $(BINDIR)/$(EXE)::' -i Makefile \
- || die 'failed to disable stripping in the Makefile'
-}
-
-src_compile() {
- local my_arch
-
- # generic unoptimized first
- use general-32 && my_arch=general-32
- use general-64 && my_arch=general-64
-
- # x86
- use x86 && my_arch=x86-32-old
- use cpu_flags_x86_sse && my_arch=x86-32
-
- # amd64
- use amd64 && my_arch=x86-64
- use cpu_flags_x86_popcnt && my_arch=x86-64-modern
-
- # both bmi2 and avx2 are part of hni (haswell new instructions)
- use cpu_flags_x86_avx2 && my_arch=x86-64-bmi2
-
- # other architectures
- use armv7 && my_arch=armv7
- use ppc && my_arch=ppc
- use ppc64 && my_arch=ppc64
-
- # Skip the "build" target and use "all" instead to avoid the config
- # sanity check (which would throw a fit about our compiler). There's
- # a nice hack in the Makefile that overrides the value of CXX with
- # COMPILER to support Travis CI and we abuse it to make sure that we
- # build with our compiler of choice.
- emake all ARCH="${my_arch}" \
- COMP=$(tc-getCXX) \
- COMPILER=$(tc-getCXX) \
- debug=$(usex debug "yes" "no") \
- optimize=$(usex optimize "yes" "no")
-}
-
-src_install() {
- dobin "${PN}"
- dodoc ../AUTHORS ../Readme.md
-}