summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2022-04-20 08:01:57 +0000
committerPatrick Lauer <patrick@gentoo.org>2022-04-20 08:01:57 +0000
commit7fb90707f9879732ece1a9831980f62b960999ee (patch)
treee0b25662cb7f7b0ddba0783e1b0bef4cc50520aa /games-board/stockfish
parentdev-java/gwt: drop 2.9.0-r2 (diff)
downloadgentoo-7fb90707f9879732ece1a9831980f62b960999ee.tar.gz
gentoo-7fb90707f9879732ece1a9831980f62b960999ee.tar.bz2
gentoo-7fb90707f9879732ece1a9831980f62b960999ee.zip
games-board/stockfish: Bump to 15
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'games-board/stockfish')
-rw-r--r--games-board/stockfish/Manifest2
-rw-r--r--games-board/stockfish/stockfish-15.ebuild74
2 files changed, 76 insertions, 0 deletions
diff --git a/games-board/stockfish/Manifest b/games-board/stockfish/Manifest
index 847669906340..56a3e17f5a6b 100644
--- a/games-board/stockfish/Manifest
+++ b/games-board/stockfish/Manifest
@@ -5,3 +5,5 @@ DIST stockfish-14-nn-3475407dc199.nnue 47721371 BLAKE2B e0d21fb2c282bb6c07a02747
DIST stockfish-14.1-nn-13406b1dcbe0.nnue 47001243 BLAKE2B ef7deeeac9d4fb03e70695978b57d5f5e0861d4e1b5af4f6c5decade689a81f238553f87fbc06741c931dea6b5b672bd585df61f5960378e67fe3aa25b74b709 SHA512 89b1242262d10aba9de168d5fdcaf70b36f9ad84d79eca7245591174c679473d60251b30d8a05100967fd5bf0e8e59632749d6d77f2bbdce0a3f77b8d15dd5cc
DIST stockfish-14.1.tar.gz 187792 BLAKE2B 84ed9da634a1e52579d0aa1ef356cd31a350ecafc44ebc632080b1c6c2c01d7a2cab8d7ab44065abd140b74e65bdcea8e3cc0a5e5c5daca8060303798df90c6f SHA512 b45ec44ba88a22e528a9ae417135851ace75006d0295eb77ab92dd1dc08f3c445a50047b1f2a4a7ab73773b2ce07bd98b601e40c6f75a63586c565cec5e33039
DIST stockfish-14.tar.gz 183879 BLAKE2B fd2fbcd37f90baf6b81432ebee7aa5b949c05253e04ec361fa502687de597e90aa6c85a90a5fd1baea52da423264d8e14853303564c3bc6f37bc98de890c5d3c SHA512 90025c0559d09f950732c051362711bed7f22e5495daeadf1ac8d7b1be9ede7e9aff80ca8755fccd95bdb48e2b2ea4b4355e02cd9112ac8e5eec457774289f34
+DIST stockfish-15-nn-6877cd24400e.nnue 47001499 BLAKE2B 12d9c250e7fc920aa1c575bdfa280ee648419307d7bb30dbda0e52a7a4b92a15063fba9a00e04c4201602d8778e181f8fff73a2f5a2963f197fb30020fdf78a0 SHA512 456961b01c7b7a852ac23eb9de8aca65204d5d0566868c998eb8918abd9c9eef7f7fb08ac08a7750eaede451859f93a15e92e1a14ecc269268dadb9a7b0eb135
+DIST stockfish-15.tar.gz 189578 BLAKE2B 49af86be2d926ad51021edc119fee260d54fbb37d22d9e0883c382a60d6d0f742b7eee5df296b1dc85552e24269e97c172df70e0a894b328e5bfa92d0614d608 SHA512 d79f713654d5ff0b7f158394c887dce015ef613242e52ef55575c024255da6f6a6bdfe974ff1037599fc99ddfdc2774e37bbc6b8fc88ed0df59590f820a27ffa
diff --git a/games-board/stockfish/stockfish-15.ebuild b/games-board/stockfish/stockfish-15.ebuild
new file mode 100644
index 000000000000..42d1b704aea0
--- /dev/null
+++ b/games-board/stockfish/stockfish-15.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Free UCI chess engine, claimed to be the strongest in the world"
+HOMEPAGE="https://stockfishchess.org/"
+
+NNUE_FILE="nn-6877cd24400e.nnue"
+
+SRC_URI="https://github.com/official-stockfish/Stockfish/archive/sf_${PV}.tar.gz -> ${P}.tar.gz
+ https://tests.stockfishchess.org/api/nn/${NNUE_FILE} -> ${P}-${NNUE_FILE}"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="cpu_flags_arm_v7 cpu_flags_x86_avx2 cpu_flags_x86_popcnt cpu_flags_x86_sse debug
+ general-32 general-64 +optimize"
+
+DEPEND="|| ( app-arch/unzip app-arch/zip )"
+RDEPEND=""
+
+S="${WORKDIR}/Stockfish-sf_${PV}/src"
+
+src_prepare() {
+ default
+
+ cp "${DISTDIR}"/${P}-${NNUE_FILE} ${NNUE_FILE} || die "copying the nnue file failed"
+
+ # prevent pre-stripping
+ sed -e 's:-strip $(BINDIR)/$(EXE)::' -i Makefile \
+ || die 'failed to disable stripping in the Makefile'
+}
+
+src_compile() {
+ local my_arch
+
+ # generic unoptimized first
+ use general-32 && my_arch=general-32
+ use general-64 && my_arch=general-64
+
+ # x86
+ use x86 && my_arch=x86-32-old
+ use cpu_flags_x86_sse && my_arch=x86-32
+
+ # amd64
+ use amd64 && my_arch=x86-64
+ use cpu_flags_x86_popcnt && my_arch=x86-64-modern
+
+ # both bmi2 and avx2 are part of hni (haswell new instructions)
+ use cpu_flags_x86_avx2 && my_arch=x86-64-bmi2
+
+ # other architectures
+ use cpu_flags_arm_v7 && my_arch=armv7
+ use ppc && my_arch=ppc
+ use ppc64 && my_arch=ppc64
+
+ # Skip the "build" target and use "all" instead to avoid the config
+ # sanity check (which would throw a fit about our compiler). There's
+ # a nice hack in the Makefile that overrides the value of CXX with
+ # COMPILER to support Travis CI and we abuse it to make sure that we
+ # build with our compiler of choice.
+ emake all ARCH="${my_arch}" \
+ COMP="$(tc-getCXX)" \
+ COMPILER="$(tc-getCXX)" \
+ debug=$(usex debug "yes" "no") \
+ optimize=$(usex optimize "yes" "no")
+}
+
+src_install() {
+ dobin "${PN}"
+ dodoc ../AUTHORS ../README.md
+}