summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2020-02-27 19:09:35 -0600
committerMatthias Maier <tamiko@gentoo.org>2020-02-27 19:16:51 -0600
commite3629f5638ac3db3b78cba39c05250882fad2746 (patch)
treebb7aa668c392deaf1ea4256015bdf2f822ba4247 /games-board/stockfish
parentgames-board/stockfish: port to proper cpu_flags_arm use flag (diff)
downloadgentoo-e3629f5638ac3db3b78cba39c05250882fad2746.tar.gz
gentoo-e3629f5638ac3db3b78cba39c05250882fad2746.tar.bz2
gentoo-e3629f5638ac3db3b78cba39c05250882fad2746.zip
games-board/stockfish: version bump to 11
Closes: https://bugs.gentoo.org/709784 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'games-board/stockfish')
-rw-r--r--games-board/stockfish/Manifest1
-rw-r--r--games-board/stockfish/stockfish-11.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/games-board/stockfish/Manifest b/games-board/stockfish/Manifest
index ec4790075f0a..b76b0028dbd5 100644
--- a/games-board/stockfish/Manifest
+++ b/games-board/stockfish/Manifest
@@ -1 +1,2 @@
DIST stockfish-10-src.zip 174377 BLAKE2B 58142b16f59f15773c8811d6e10588dbc680c94cd504d26f4ca285dbe632d845ede06571e501a4e2b77adbb9b00d91978236ff179a46a73dc9a03cfa1ae3490c SHA512 959c4f3c497ba3108884dabc38de824f11781ae57b4ab5fdf25daf9a7fc0326e663adb1c081b8c8d57a7bf5f2e941369502a50a0c93135a001c6bd1af360d0f8
+DIST stockfish-11.zip 179371 BLAKE2B c58839e8c8f8b9424f93555316c9cddccc8dec8cc29dde52bfd73af0d6c727b3a94eea07db08ebc88b97986b814a3a53e22726cdece0fbdbb54a131cec591d64 SHA512 5291a8200172d37f5a94711aeeb65b11d7a9b9ccc366182c4c6a8b454dd4fad72bf19d1494fe091cb71502288f81ec3c7d0fa16b815af7fc76b2894cb26dc8f4
diff --git a/games-board/stockfish/stockfish-11.ebuild b/games-board/stockfish/stockfish-11.ebuild
new file mode 100644
index 000000000000..c0198fa586c7
--- /dev/null
+++ b/games-board/stockfish/stockfish-11.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Free UCI chess engine, claimed to be the strongest in the world"
+HOMEPAGE="https://stockfishchess.org/"
+
+SRC_URI="https://github.com/official-stockfish/Stockfish/archive/sf_${PV}.zip -> ${P}.zip"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cpu_flags_arm_v7 cpu_flags_x86_avx2 cpu_flags_x86_popcnt cpu_flags_x86_sse debug
+ general-32 general-64 +optimize"
+
+DEPEND="|| ( app-arch/unzip app-arch/zip )"
+RDEPEND=""
+
+S="${WORKDIR}/Stockfish-sf_${PV}/src"
+
+src_prepare() {
+ default
+
+ # prevent pre-stripping
+ sed -e 's:-strip $(BINDIR)/$(EXE)::' -i Makefile \
+ || die 'failed to disable stripping in the Makefile'
+}
+
+src_compile() {
+ local my_arch
+
+ # generic unoptimized first
+ use general-32 && my_arch=general-32
+ use general-64 && my_arch=general-64
+
+ # x86
+ use x86 && my_arch=x86-32-old
+ use cpu_flags_x86_sse && my_arch=x86-32
+
+ # amd64
+ use amd64 && my_arch=x86-64
+ use cpu_flags_x86_popcnt && my_arch=x86-64-modern
+
+ # both bmi2 and avx2 are part of hni (haswell new instructions)
+ use cpu_flags_x86_avx2 && my_arch=x86-64-bmi2
+
+ # other architectures
+ use cpu_flags_arm_v7 && my_arch=armv7
+ use ppc && my_arch=ppc
+ use ppc64 && my_arch=ppc64
+
+ # Skip the "build" target and use "all" instead to avoid the config
+ # sanity check (which would throw a fit about our compiler). There's
+ # a nice hack in the Makefile that overrides the value of CXX with
+ # COMPILER to support Travis CI and we abuse it to make sure that we
+ # build with our compiler of choice.
+ emake all ARCH="${my_arch}" \
+ COMP=$(tc-getCXX) \
+ COMPILER=$(tc-getCXX) \
+ debug=$(usex debug "yes" "no") \
+ optimize=$(usex optimize "yes" "no")
+}
+
+src_install() {
+ dobin "${PN}"
+ dodoc ../AUTHORS ../Readme.md
+}