summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-08-01 13:47:25 -0500
committerAustin English <wizardedit@gentoo.org>2016-08-01 13:50:17 -0500
commit636a661e83744745ae24312cd1105825111890d1 (patch)
tree923b88a415cdaf751120a897e59eb6b06be7948f /games-board/xfreecell
parentgames-board/xgammon: remove deprecated games eclass (diff)
downloadgentoo-636a661e83744745ae24312cd1105825111890d1.tar.gz
gentoo-636a661e83744745ae24312cd1105825111890d1.tar.bz2
gentoo-636a661e83744745ae24312cd1105825111890d1.zip
games-board/xfreecell: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
Diffstat (limited to 'games-board/xfreecell')
-rw-r--r--games-board/xfreecell/files/xfreecell-1.0.5b-gcc43.patch20
-rw-r--r--games-board/xfreecell/files/xfreecell-1.0.5b-gentoo.patch56
-rw-r--r--games-board/xfreecell/xfreecell-1.0.5b-r1.ebuild41
3 files changed, 79 insertions, 38 deletions
diff --git a/games-board/xfreecell/files/xfreecell-1.0.5b-gcc43.patch b/games-board/xfreecell/files/xfreecell-1.0.5b-gcc43.patch
index cf7e899d2856..aa3b434e151f 100644
--- a/games-board/xfreecell/files/xfreecell-1.0.5b-gcc43.patch
+++ b/games-board/xfreecell/files/xfreecell-1.0.5b-gcc43.patch
@@ -1,5 +1,5 @@
---- card.cpp
-+++ card.cpp
+--- a/card.cpp
++++ b/card.cpp
@@ -1,5 +1,6 @@
+#include <cstdlib>
#include <cstdio>
@@ -8,8 +8,8 @@
#ifdef SHAPE
#include <X11/Xlib.h>
#include <X11/Xutil.h>
---- freecell.cpp
-+++ freecell.cpp
+--- a/freecell.cpp
++++ b/freecell.cpp
@@ -1,6 +1,7 @@
#include <dirent.h>
#include <fcntl.h>
@@ -19,8 +19,8 @@
#include <sys/stat.h>
#include <sys/time.h>
#include <sys/types.h>
---- option.cpp
-+++ option.cpp
+--- a/option.cpp
++++ b/option.cpp
@@ -3,7 +3,9 @@
#include <fcntl.h>
#include <dirent.h>
@@ -32,8 +32,8 @@
#include "general.h"
#include "option.h"
---- subwindows.cpp
-+++ subwindows.cpp
+--- a/subwindows.cpp
++++ b/subwindows.cpp
@@ -3,7 +3,8 @@
#include <fcntl.h>
#include <dirent.h>
@@ -44,8 +44,8 @@
#include "general.h"
#include "subwindows.h"
---- widget/widget.h
-+++ widget/widget.h
+--- a/widget/widget.h
++++ b/widget/widget.h
@@ -4,7 +4,9 @@
#include <X11/Xlib.h>
#include <X11/Xutil.h>
diff --git a/games-board/xfreecell/files/xfreecell-1.0.5b-gentoo.patch b/games-board/xfreecell/files/xfreecell-1.0.5b-gentoo.patch
index f000eb7347d5..85a2e4dd3c41 100644
--- a/games-board/xfreecell/files/xfreecell-1.0.5b-gentoo.patch
+++ b/games-board/xfreecell/files/xfreecell-1.0.5b-gentoo.patch
@@ -1,5 +1,5 @@
-diff -ru xfreecell.orig/card.cpp xfreecell/card.cpp
---- xfreecell.orig/card.cpp 1999-03-27 05:36:28.000000000 -0800
+diff -ru xfreecellg/card.cpp xfreecell/card.cpp
+--- xfreecellg/card.cpp 1999-03-27 05:36:28.000000000 -0800
+++ xfreecell/card.cpp 2004-02-25 02:17:24.000000000 -0800
@@ -119,7 +119,7 @@
int oldy = y();
@@ -10,8 +10,8 @@ diff -ru xfreecell.orig/card.cpp xfreecell/card.cpp
float curx = (float) oldx;
float cury = (float) oldy;
-diff -ru xfreecell.orig/freecell.cpp xfreecell/freecell.cpp
---- xfreecell.orig/freecell.cpp 1999-07-27 07:15:27.000000000 -0700
+diff -ru xfreecellg/freecell.cpp xfreecell/freecell.cpp
+--- xfreecellg/freecell.cpp 1999-07-27 07:15:27.000000000 -0700
+++ xfreecell/freecell.cpp 2004-02-25 02:18:13.000000000 -0800
@@ -64,7 +64,7 @@
static GameNumberManager* gnManager;
@@ -31,8 +31,8 @@ diff -ru xfreecell.orig/freecell.cpp xfreecell/freecell.cpp
if (home == NULL) {
fprintf(stderr, "Cannot get $HOME. Assuming I am at home directory now.\n");
-diff -ru xfreecell.orig/gnmanager.cpp xfreecell/gnmanager.cpp
---- xfreecell.orig/gnmanager.cpp 1999-07-27 07:18:05.000000000 -0700
+diff -ru xfreecellg/gnmanager.cpp xfreecell/gnmanager.cpp
+--- xfreecellg/gnmanager.cpp 1999-07-27 07:18:05.000000000 -0700
+++ xfreecell/gnmanager.cpp 2004-02-25 02:17:24.000000000 -0800
@@ -16,7 +16,7 @@
GameNumberManager::GameNumberManager()
@@ -61,8 +61,8 @@ diff -ru xfreecell.orig/gnmanager.cpp xfreecell/gnmanager.cpp
{
FILE* fp = fopen(file.c_str(), "w+");
-diff -ru xfreecell.orig/gnmanager.h xfreecell/gnmanager.h
---- xfreecell.orig/gnmanager.h 1999-03-29 05:07:19.000000000 -0800
+diff -ru xfreecellg/gnmanager.h xfreecell/gnmanager.h
+--- xfreecellg/gnmanager.h 1999-03-29 05:07:19.000000000 -0800
+++ xfreecell/gnmanager.h 2004-02-25 02:17:24.000000000 -0800
@@ -2,7 +2,13 @@
#define GNManager_H
@@ -98,8 +98,8 @@ diff -ru xfreecell.orig/gnmanager.h xfreecell/gnmanager.h
hash_set<int> msWonGames;
hash_set<int> msLostGames;
-diff -ru xfreecell.orig/makefile xfreecell/makefile
---- xfreecell.orig/makefile 1999-04-03 05:42:49.000000000 -0800
+diff -ru xfreecellg/makefile xfreecell/makefile
+--- xfreecellg/makefile 1999-04-03 05:42:49.000000000 -0800
+++ xfreecell/makefile 2004-02-25 02:17:48.000000000 -0800
@@ -1,16 +1,15 @@
OBJECTS=card.o freecell.o option.o stack.o subwindows.o undo.o util.o gnmanager.o random.o
@@ -146,8 +146,8 @@ diff -ru xfreecell.orig/makefile xfreecell/makefile
-# install ms-compatible/MSNumbers $(DESTDIR)/usr/local/lib/xfreecell
\ No newline at end of file
+# install ms-compatible/MSNumbers $(DESTDIR)/usr/share/xfreecell
-diff -ru xfreecell.orig/option.h xfreecell/option.h
---- xfreecell.orig/option.h 1999-03-27 11:39:17.000000000 -0800
+diff -ru xfreecellg/option.h xfreecell/option.h
+--- xfreecellg/option.h 1999-03-27 11:39:17.000000000 -0800
+++ xfreecell/option.h 2004-02-25 02:17:24.000000000 -0800
@@ -22,7 +22,7 @@
void readPrefs();
@@ -158,8 +158,8 @@ diff -ru xfreecell.orig/option.h xfreecell/option.h
static int _speedup;
static bool _queryWindow;
-diff -ru xfreecell.orig/stack.h xfreecell/stack.h
---- xfreecell.orig/stack.h 1999-03-02 10:20:02.000000000 -0800
+diff -ru xfreecellg/stack.h xfreecell/stack.h
+--- xfreecellg/stack.h 1999-03-02 10:20:02.000000000 -0800
+++ xfreecell/stack.h 2004-02-25 02:17:24.000000000 -0800
@@ -28,7 +28,7 @@
int _next_x, _next_y;
@@ -170,8 +170,8 @@ diff -ru xfreecell.orig/stack.h xfreecell/stack.h
};
class PlayStack : public Stack {
-diff -ru xfreecell.orig/subwindows.h xfreecell/subwindows.h
---- xfreecell.orig/subwindows.h 1999-03-15 15:09:49.000000000 -0800
+diff -ru xfreecellg/subwindows.h xfreecell/subwindows.h
+--- xfreecellg/subwindows.h 1999-03-15 15:09:49.000000000 -0800
+++ xfreecell/subwindows.h 2004-02-25 02:17:24.000000000 -0800
@@ -76,7 +76,7 @@
int _undos;
@@ -182,8 +182,8 @@ diff -ru xfreecell.orig/subwindows.h xfreecell/subwindows.h
bool exitPressed;
-diff -ru xfreecell.orig/undo.cpp xfreecell/undo.cpp
---- xfreecell.orig/undo.cpp 1999-03-25 07:48:40.000000000 -0800
+diff -ru xfreecellg/undo.cpp xfreecell/undo.cpp
+--- xfreecellg/undo.cpp 1999-03-25 07:48:40.000000000 -0800
+++ xfreecell/undo.cpp 2004-02-25 02:17:24.000000000 -0800
@@ -22,7 +22,7 @@
c->moveToStack(from, false, false);
@@ -194,8 +194,8 @@ diff -ru xfreecell.orig/undo.cpp xfreecell/undo.cpp
void undoClearMoves()
{
-diff -ru xfreecell.orig/widget/container.cpp xfreecell/widget/container.cpp
---- xfreecell.orig/widget/container.cpp 1999-03-03 09:34:52.000000000 -0800
+diff -ru xfreecellg/widget/container.cpp xfreecell/widget/container.cpp
+--- xfreecellg/widget/container.cpp 1999-03-03 09:34:52.000000000 -0800
+++ xfreecell/widget/container.cpp 2004-02-25 02:17:24.000000000 -0800
@@ -61,18 +61,18 @@
@@ -233,8 +233,8 @@ diff -ru xfreecell.orig/widget/container.cpp xfreecell/widget/container.cpp
if (nscVec.size() == 0) {
_width = 0; _height = 0;
} else {
-diff -ru xfreecell.orig/widget/makefile xfreecell/widget/makefile
---- xfreecell.orig/widget/makefile 1999-03-17 21:54:57.000000000 -0800
+diff -ru xfreecellg/widget/makefile xfreecell/widget/makefile
+--- xfreecellg/widget/makefile 1999-03-17 21:54:57.000000000 -0800
+++ xfreecell/widget/makefile 2004-02-25 02:17:59.000000000 -0800
@@ -1,15 +1,13 @@
OBJECTS=window.o plate.o string.o button.o label.o textfield.o container.o frame.o util.o scrollbar.o font.o main.o
@@ -255,16 +255,16 @@ diff -ru xfreecell.orig/widget/makefile xfreecell/widget/makefile
clean:
rm -f *.o *~ a.out .nfs* dummy
-diff -ru xfreecell.orig/widget/textfield.cpp xfreecell/widget/textfield.cpp
---- xfreecell.orig/widget/textfield.cpp 1999-03-03 09:34:52.000000000 -0800
+diff -ru xfreecellg/widget/textfield.cpp xfreecell/widget/textfield.cpp
+--- xfreecellg/widget/textfield.cpp 1999-03-03 09:34:52.000000000 -0800
+++ xfreecell/widget/textfield.cpp 2004-02-25 02:17:24.000000000 -0800
@@ -1,3 +1,4 @@
+#include <cctype>
#include "widget.h"
GC NSTextField::gc;
-diff -ru xfreecell.orig/widget/widget.h xfreecell/widget/widget.h
---- xfreecell.orig/widget/widget.h 1999-03-15 08:29:32.000000000 -0800
+diff -ru xfreecellg/widget/widget.h xfreecell/widget/widget.h
+--- xfreecellg/widget/widget.h 1999-03-15 08:29:32.000000000 -0800
+++ xfreecell/widget/widget.h 2004-02-25 02:17:24.000000000 -0800
@@ -114,7 +114,7 @@
Elt(NSWindow* nw, Window w) { nswindow = nw; window = w; }
@@ -302,8 +302,8 @@ diff -ru xfreecell.orig/widget/widget.h xfreecell/widget/widget.h
};
// ##### NSHContainer #####
-diff -ru xfreecell.orig/widget/window.cpp xfreecell/widget/window.cpp
---- xfreecell.orig/widget/window.cpp 1999-03-03 09:34:52.000000000 -0800
+diff -ru xfreecellg/widget/window.cpp xfreecell/widget/window.cpp
+--- xfreecellg/widget/window.cpp 1999-03-03 09:34:52.000000000 -0800
+++ xfreecell/widget/window.cpp 2004-02-25 02:17:24.000000000 -0800
@@ -2,7 +2,7 @@
diff --git a/games-board/xfreecell/xfreecell-1.0.5b-r1.ebuild b/games-board/xfreecell/xfreecell-1.0.5b-r1.ebuild
new file mode 100644
index 000000000000..232e308ddcd7
--- /dev/null
+++ b/games-board/xfreecell/xfreecell-1.0.5b-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="A freecell game for X"
+HOMEPAGE="http://www2.giganet.net/~nakayama/"
+SRC_URI="http://www2.giganet.net/~nakayama/${P}.tgz
+ http://www2.giganet.net/~nakayama/MSNumbers.gz"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="media-fonts/font-misc-misc
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto"
+
+S=${WORKDIR}/${PN}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-gcc43.patch
+)
+
+src_install() {
+ dobin xfreecell
+ insinto /usr/share/${PN}
+ doins "${WORKDIR}"/MSNumbers
+ dodoc CHANGES README mshuffle.txt
+ doman xfreecell.6
+ make_desktop_entry xfreecell XFreecell
+}
+
+pkg_postinst() {
+ einfo "Remember to restart X if this is the first time you've installed media-fonts/font-misc-misc"
+}