summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-07-05 22:05:44 +0200
committerDavid Seifert <soap@gentoo.org>2020-07-05 22:05:44 +0200
commit4d09ab946a7e19abdfa549a585e7a54128e44480 (patch)
tree9f695bac5dd6710f4066259db032e41a9ac28779 /games-board/xmahjongg
parentgames-action/heroes: Call AM_PROG_AR (diff)
downloadgentoo-4d09ab946a7e19abdfa549a585e7a54128e44480.tar.gz
gentoo-4d09ab946a7e19abdfa549a585e7a54128e44480.tar.bz2
gentoo-4d09ab946a7e19abdfa549a585e7a54128e44480.zip
games-board/xmahjongg: Call AM_PROG_AR
Closes: https://bugs.gentoo.org/730800 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'games-board/xmahjongg')
-rw-r--r--games-board/xmahjongg/files/xmahjongg-3.7-autotools.patch26
-rw-r--r--games-board/xmahjongg/xmahjongg-3.7-r1.ebuild16
2 files changed, 35 insertions, 7 deletions
diff --git a/games-board/xmahjongg/files/xmahjongg-3.7-autotools.patch b/games-board/xmahjongg/files/xmahjongg-3.7-autotools.patch
new file mode 100644
index 000000000000..9efc02399804
--- /dev/null
+++ b/games-board/xmahjongg/files/xmahjongg-3.7-autotools.patch
@@ -0,0 +1,26 @@
+--- a/configure.in
++++ b/configure.in
+@@ -9,8 +9,11 @@
+ AC_PROG_CPP
+ AC_PROG_CXX
+ AC_PROG_CXXCPP
++AM_PROG_AR
+ AC_PROG_RANLIB
+-if test -n "$GCC" ; then CC="$CC -Wall"; CXX="$CXX -Wall"; fi
++
++CFLAGS="${CFLAGS} -Wall"
++CXXFLAGS="${CXXFLAGS} -Wall"
+
+ AC_PATH_XTRA
+
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -32,7 +32,7 @@
+
+ INCLUDES = $(X_CFLAGS) -I$(top_srcdir)/include
+
+-xmahjongg_LDADD = $(LDADD) ../liblcdf/liblcdf.a @X_LIBS@ @X_PRE_LIBS@ -lX11 @X_EXTRA_LIBS@
++xmahjongg_LDADD = $(LDADD) ../liblcdf/liblcdf.a @X_LIBS@ -lX11 @X_EXTRA_LIBS@
+
+
+ #
diff --git a/games-board/xmahjongg/xmahjongg-3.7-r1.ebuild b/games-board/xmahjongg/xmahjongg-3.7-r1.ebuild
index e05ea7454d84..15198d767d8a 100644
--- a/games-board/xmahjongg/xmahjongg-3.7-r1.ebuild
+++ b/games-board/xmahjongg/xmahjongg-3.7-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils
+EAPI=7
+
+inherit autotools desktop
DESCRIPTION="friendly GUI version of xmahjongg"
HOMEPAGE="http://www.lcdf.org/xmahjongg/"
@@ -11,21 +12,22 @@ SRC_URI="http://www.lcdf.org/xmahjongg/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~mips ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE=""
RDEPEND="x11-libs/libX11"
DEPEND="${RDEPEND}
x11-libs/libXt"
+PATCHES=( "${FILESDIR}"/${P}-autotools.patch )
+
src_prepare() {
default
- sed -i \
- -e '/X_PRE_LIBS/s:-lSM -lICE::' \
- configure || die
+ mv configure.{in,ac} || die
+ eautoreconf
}
src_install() {
default
+
newicon share/tiles/small.gif ${PN}.gif
make_desktop_entry xmahjongg "Xmahjongg" /usr/share/pixmaps/${PN}.gif
}