summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-29 10:19:45 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-29 13:25:00 +0200
commitd324ca4cf87388b50d82146452a0cfebcd74e2c5 (patch)
tree636120e85a75dcd36617ad7b072d9419a46a1856 /games-board/xmille
parentgames-board/spider: Make repoman happy (diff)
downloadgentoo-d324ca4cf87388b50d82146452a0cfebcd74e2c5.tar.gz
gentoo-d324ca4cf87388b50d82146452a0cfebcd74e2c5.tar.bz2
gentoo-d324ca4cf87388b50d82146452a0cfebcd74e2c5.zip
games-board/xmille: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-board/xmille')
-rw-r--r--games-board/xmille/Manifest1
-rw-r--r--games-board/xmille/xmille-2.0-r3.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/games-board/xmille/Manifest b/games-board/xmille/Manifest
index 6f03acf7f379..8c0a3eba8b2b 100644
--- a/games-board/xmille/Manifest
+++ b/games-board/xmille/Manifest
@@ -1,2 +1,3 @@
DIST xmille_2.0-12.diff.gz 6041 BLAKE2B 3c901cccdacf7306420c5de98618ea0468a96ef42a61d5d9f0cbb4e655269c1eb38fab8acfc77830978ea90ed7c424c9236efa16b70f33ef53a36076a6dd6e9f SHA512 8f8a71ce6f4359b4d8fbecd0e6149783abc4ded07da485c91c67784fd6c4988d074ad9bda7a8a47689ffe379dd8d20f9968ef7e6998ed22b735c51a2fae5828d
+DIST xmille_2.0-13.diff.gz 6276 BLAKE2B bf136bc25d3aea56b671b6ff475717d162f0620a1c8c07d3b96b9d7a4b9b9f3ccae1039fc24827048686c631312c36e450a8bd989c32e9d26ab1c594ffc317d9 SHA512 d9e4448942738a105255d9aa77e2e66cb9edc8b35fd8278d1c810dbdca4a5b8a4916bf48c8d6a16e282db0c0fa058a0b281c168976529edeedb6caf53af7cd15
DIST xmille_2.0.orig.tar.gz 68178 BLAKE2B bd6ab40a8868b90bfc1b045a2be797c8eab49e676b695f521ceaf8646de9c01a07806c0ce029e4959a339e2ab48668635abd5b842c90e33c2cb5fd359eb971b8 SHA512 028740785dfc13b4088810855358b9dab75fbb79221dd4218ef0c19550c2180fe92e553d0a474bf45091b4008988e1a093a6d5bac99fe1ccafcaec3429cd0e8b
diff --git a/games-board/xmille/xmille-2.0-r3.ebuild b/games-board/xmille/xmille-2.0-r3.ebuild
new file mode 100644
index 000000000000..7821de3430bb
--- /dev/null
+++ b/games-board/xmille/xmille-2.0-r3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop epatch toolchain-funcs
+
+DEB_PATCH_VER="13"
+DESCRIPTION="Mille Bournes card game"
+HOMEPAGE="http://www.milleborne.info/"
+SRC_URI="mirror://debian/pool/main/x/xmille/${PN}_${PV}.orig.tar.gz
+ mirror://debian/pool/main/x/xmille/${PN}_${PV}-${DEB_PATCH_VER}.diff.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libXext"
+DEPEND="${RDEPEND}
+ app-text/rman
+ x11-misc/imake
+"
+
+S="${WORKDIR}/${P}.orig"
+
+src_prepare() {
+ default
+ epatch "${WORKDIR}"/${PN}_${PV}-${DEB_PATCH_VER}.diff
+
+}
+
+src_configure() {
+ xmkmf || die
+}
+
+src_compile() {
+ emake -j1 \
+ AR="$(tc-getAR) clq" \
+ RANLIB="$(tc-getRANLIB)" \
+ CC="$(tc-getCC)" \
+ CDEBUGFLAGS="${CFLAGS}" \
+ EXTRA_LDOPTIONS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin xmille
+ einstalldocs
+ make_desktop_entry "${PN}" "Milles Bournes"
+ newman xmille.man xmille.6
+}