summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-09-07 09:13:02 +0200
committerDavid Seifert <soap@gentoo.org>2017-09-07 09:13:20 +0200
commit1f6eeb3ae3f00b88fa38398613a63d08422e320f (patch)
treea5e353f34cc344e4429d7d641915064eeb0d9f14 /games-board
parentxen (diff)
downloadgentoo-1f6eeb3ae3f00b88fa38398613a63d08422e320f.tar.gz
gentoo-1f6eeb3ae3f00b88fa38398613a63d08422e320f.tar.bz2
gentoo-1f6eeb3ae3f00b88fa38398613a63d08422e320f.zip
games-board/pokerth: Fully qualify std::advance
Closes: https://bugs.gentoo.org/show_bug.cgi?id=629966 Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'games-board')
-rw-r--r--games-board/pokerth/files/pokerth-1.1.1-boost-1.65-ambiguous-advance.patch14
-rw-r--r--games-board/pokerth/pokerth-1.1.1-r2.ebuild9
2 files changed, 19 insertions, 4 deletions
diff --git a/games-board/pokerth/files/pokerth-1.1.1-boost-1.65-ambiguous-advance.patch b/games-board/pokerth/files/pokerth-1.1.1-boost-1.65-ambiguous-advance.patch
new file mode 100644
index 000000000000..2e8c9c50c5eb
--- /dev/null
+++ b/games-board/pokerth/files/pokerth-1.1.1-boost-1.65-ambiguous-advance.patch
@@ -0,0 +1,14 @@
+Boost 1.65 made 'advance()' ambiguous.
+Bug: https://bugs.gentoo.org/show_bug.cgi?id=629966
+
+--- a/src/gui/qt/gametable/gametableimpl.cpp
++++ b/src/gui/qt/gametable/gametableimpl.cpp
+@@ -3859,7 +3859,7 @@
+ int playerCount = static_cast<int>(seatList->size());
+ if (id < playerCount) {
+ PlayerListIterator pos = seatList->begin();
+- advance(pos, id);
++ std::advance(pos, id);
+ myStartWindow->getSession()->startVoteKickPlayer((*pos)->getMyUniqueID());
+ }
+ }
diff --git a/games-board/pokerth/pokerth-1.1.1-r2.ebuild b/games-board/pokerth/pokerth-1.1.1-r2.ebuild
index 32e456bf3d70..be20d0fd206f 100644
--- a/games-board/pokerth/pokerth-1.1.1-r2.ebuild
+++ b/games-board/pokerth/pokerth-1.1.1-r2.ebuild
@@ -38,10 +38,11 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}
PATCHES=(
- "${FILESDIR}/${P}-qt5.patch"
- "${FILESDIR}/${P}-boost-1.60.patch"
- "${FILESDIR}/${P}-qmake-gcc-6.patch"
- "${FILESDIR}/${P}-boost-noexcept.patch"
+ "${FILESDIR}"/${PN}-1.1.1-qt5.patch
+ "${FILESDIR}"/${PN}-1.1.1-boost-1.60.patch
+ "${FILESDIR}"/${PN}-1.1.1-qmake-gcc-6.patch
+ "${FILESDIR}"/${PN}-1.1.1-boost-noexcept.patch
+ "${FILESDIR}"/${PN}-1.1.1-boost-1.65-ambiguous-advance.patch
)
src_prepare() {