summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2021-06-21 18:25:05 +0200
committerIonen Wolkens <ionen@gentoo.org>2021-06-23 21:53:59 -0400
commit2800fac798ad4cf1018e6fea464f17c2c4c26db6 (patch)
tree8dbabebe3c14708ad7f3be17c08c7b0e0d41cd37 /games-board
parentgames-action/moon-buggy: EAPI7, add missing eclass, fix LICENSE (diff)
downloadgentoo-2800fac798ad4cf1018e6fea464f17c2c4c26db6.tar.gz
gentoo-2800fac798ad4cf1018e6fea464f17c2c4c26db6.tar.bz2
gentoo-2800fac798ad4cf1018e6fea464f17c2c4c26db6.zip
games-board/cockatrice: fix LICENSE, add missing eclass
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-board')
-rw-r--r--games-board/cockatrice/cockatrice-20210126.ebuild32
1 files changed, 12 insertions, 20 deletions
diff --git a/games-board/cockatrice/cockatrice-20210126.ebuild b/games-board/cockatrice/cockatrice-20210126.ebuild
index f3f5bd2606f3..caa652ceef6e 100644
--- a/games-board/cockatrice/cockatrice-20210126.ebuild
+++ b/games-board/cockatrice/cockatrice-20210126.ebuild
@@ -3,14 +3,16 @@
EAPI=7
-inherit cmake
+inherit xdg cmake
MY_PV="2021-01-26-Release-2.8.0"
-DESCRIPTION="An open-source multiplatform software for playing card games over a network"
+
+DESCRIPTION="Open-source multiplatform software for playing card games over a network"
HOMEPAGE="https://github.com/Cockatrice/Cockatrice"
SRC_URI="https://github.com/Cockatrice/Cockatrice/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/Cockatrice-${MY_PV}"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+client +oracle test server"
@@ -33,17 +35,14 @@ RDEPEND="
server? (
dev-libs/protobuf:=
dev-qt/qtsql:5
- )
-"
+ )"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-cpp/gtest )"
BDEPEND="
dev-qt/linguist-tools:5
client? ( dev-libs/protobuf )
- server? ( dev-libs/protobuf )
- test? ( dev-cpp/gtest )
-"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/Cockatrice-${MY_PV}"
+ server? ( dev-libs/protobuf )"
src_configure() {
local mycmakeargs=(
@@ -54,7 +53,8 @@ src_configure() {
-DWITH_SERVER=$(usex server)
-DTEST=$(usex test)
-DICONDIR="${EPREFIX}/usr/share/icons"
- -DDESKTOPDIR="${EPREFIX}/usr/share/applications" )
+ -DDESKTOPDIR="${EPREFIX}/usr/share/applications"
+ )
# Add date in the help about, come from git originally
sed -e 's/^set(PROJECT_VERSION_FRIENDLY.*/set(PROJECT_VERSION_FRIENDLY \"'${MY_PV}'\")/' \
@@ -62,11 +62,3 @@ src_configure() {
cmake_src_configure
}
-
-pkg_postinst() {
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
-}