summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-25 01:08:47 +0000
committerSam James <sam@gentoo.org>2022-01-25 01:08:47 +0000
commit58b0f5c691a22681cb9541d2d06698ccc8e33538 (patch)
treec297209001ae12a2f278be5ac95ec93dd77f5231 /games-board
parentapp-editors/gedit: fix build with meson 0.61 (diff)
downloadgentoo-58b0f5c691a22681cb9541d2d06698ccc8e33538.tar.gz
gentoo-58b0f5c691a22681cb9541d2d06698ccc8e33538.tar.bz2
gentoo-58b0f5c691a22681cb9541d2d06698ccc8e33538.zip
games-board/gnome-mines: fix build with meson 0.61
Closes: https://bugs.gentoo.org/831454 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-board')
-rw-r--r--games-board/gnome-mines/files/gnome-mines-40.0-meson-0.61.patch33
-rw-r--r--games-board/gnome-mines/gnome-mines-40.0.ebuild4
2 files changed, 37 insertions, 0 deletions
diff --git a/games-board/gnome-mines/files/gnome-mines-40.0-meson-0.61.patch b/games-board/gnome-mines/files/gnome-mines-40.0-meson-0.61.patch
new file mode 100644
index 000000000000..291fc0b403e5
--- /dev/null
+++ b/games-board/gnome-mines/files/gnome-mines-40.0-meson-0.61.patch
@@ -0,0 +1,33 @@
+https://gitlab.gnome.org/GNOME/gnome-mines/-/merge_requests/31.patch
+https://bugs.gentoo.org/831454
+
+From 0a10c3a8ae4395c8059875bcea74be5c17ef9a21 Mon Sep 17 00:00:00 2001
+From: Jan Beich <jbeich@FreeBSD.org>
+Date: Mon, 24 Jan 2022 13:28:56 +0000
+Subject: [PATCH] meson: drop unused argument for i18n.merge_file()
+
+Ignored in Meson < 0.60.0, deprecated since 0.60.1 and fatal since 0.61.0.
+
+data/meson.build:18:0: ERROR: Function does not take positional arguments.
+data/meson.build:38:0: ERROR: Function does not take positional arguments.
+--- a/data/meson.build
++++ b/data/meson.build
+@@ -15,7 +15,7 @@ foreach theme: [ 'default', 'bgcolors', 'classic' ]
+ endforeach
+ endforeach
+
+-desktop_file = i18n.merge_file ('desktop-file',
++desktop_file = i18n.merge_file (
+ input: '@0@.desktop.in'.format(app_id),
+ output: '@0@.desktop'.format(app_id),
+ install: true,
+@@ -35,7 +35,7 @@ if desktop_file_validate.found()
+ endif
+
+
+-appdata_file = i18n.merge_file ('appdata-file',
++appdata_file = i18n.merge_file (
+ input: '@0@.appdata.xml.in'.format(app_id),
+ output: '@0@.appdata.xml'.format(app_id),
+ install: true,
+GitLab
diff --git a/games-board/gnome-mines/gnome-mines-40.0.ebuild b/games-board/gnome-mines/gnome-mines-40.0.ebuild
index aba0d63de94b..39154792afb5 100644
--- a/games-board/gnome-mines/gnome-mines-40.0.ebuild
+++ b/games-board/gnome-mines/gnome-mines-40.0.ebuild
@@ -31,6 +31,10 @@ BDEPEND="
gnome-base/librsvg:2[vala]
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-40.0-meson-0.61.patch
+)
+
src_prepare() {
xdg_src_prepare
vala_src_prepare