summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-08-04 14:16:34 -0500
committerAustin English <wizardedit@gentoo.org>2016-08-04 19:22:36 -0500
commitb5fb65ce868f67fc0350ed0f10079e1261792576 (patch)
tree57e9ac5cedf834d3915f97dd52d03dd687a03397 /games-board
parentgames-board/kcheckers: remove deprecated games eclass (diff)
downloadgentoo-b5fb65ce868f67fc0350ed0f10079e1261792576.tar.gz
gentoo-b5fb65ce868f67fc0350ed0f10079e1261792576.tar.bz2
gentoo-b5fb65ce868f67fc0350ed0f10079e1261792576.zip
games-board/mah-jong: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
Diffstat (limited to 'games-board')
-rw-r--r--games-board/mah-jong/mah-jong-1.14-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/games-board/mah-jong/mah-jong-1.14-r1.ebuild b/games-board/mah-jong/mah-jong-1.14-r1.ebuild
new file mode 100644
index 000000000000..9fc2af068e53
--- /dev/null
+++ b/games-board/mah-jong/mah-jong-1.14-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils toolchain-funcs
+
+MY_P="mj-${PV}-src"
+DESCRIPTION="A networked Mah Jong program, together with a computer player"
+HOMEPAGE="http://www.stevens-bradfield.com/MahJong/"
+SRC_URI="http://mahjong.julianbradfield.org/Source/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ default
+
+ sed -i -e '/^.TH/ s/1/6/' xmj.man || die
+ sed -i \
+ -e "/^DESTDIR =/ s:=.*:= ${D}:" \
+ -e "/^BINDIR =/ s:=.*:= /usr/bin:" \
+ -e '/^MANDIR =/ s:man/man1:/usr/share/man/man6:' \
+ -e '/^MANSUFFIX =/ s:1:6:' \
+ -e "/^CC =/ s:gcc:$(tc-getCC):" \
+ -e "/^CFLAGS =/ s:=:= ${CFLAGS}:" \
+ -e "/^LDLIBS =/ s:$:${LDFLAGS}:" \
+ -e '/^INSTPGMFLAGS =/ s:-s::' \
+ -e '/^CDEBUGFLAGS =/d' \
+ -e "/^TILESETPATH=/ s:NULL:\"/usr/share/${PN}/\":" Makefile || die
+}
+
+src_install() {
+ emake install install.man
+ insinto /usr/share/${PN}
+ doins -r fallbacktiles/ tiles-numbered/ tiles-small/
+ newicon tiles-v1/tongE.xpm ${PN}.xpm
+ make_desktop_entry xmj Mah-Jong ${PN}
+ dodoc CHANGES ChangeLog *.txt
+}