summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2021-09-23 19:59:32 +0200
committerIonen Wolkens <ionen@gentoo.org>2021-09-24 03:25:50 -0400
commitd5a9e8f9d7c8bb5e9221e1376e4e165c89efbe1b (patch)
treeb2d0f1e6f3783a47597a85f99f92c349150613ad /games-board
parentdev-libs/libxml2: Fix cross-compilation with USE=python (diff)
downloadgentoo-d5a9e8f9d7c8bb5e9221e1376e4e165c89efbe1b.tar.gz
gentoo-d5a9e8f9d7c8bb5e9221e1376e4e165c89efbe1b.tar.bz2
gentoo-d5a9e8f9d7c8bb5e9221e1376e4e165c89efbe1b.zip
games-board/phalanx: EAPI8, minor improvements
Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/22378 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-board')
-rw-r--r--games-board/phalanx/phalanx-22-r1.ebuild21
1 files changed, 10 insertions, 11 deletions
diff --git a/games-board/phalanx/phalanx-22-r1.ebuild b/games-board/phalanx/phalanx-22-r1.ebuild
index cb72a63812f8..36eae23cc9df 100644
--- a/games-board/phalanx/phalanx-22-r1.ebuild
+++ b/games-board/phalanx/phalanx-22-r1.ebuild
@@ -1,30 +1,27 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
inherit toolchain-funcs
-MY_PN="Phalanx"
-MY_PV="XXII"
-MY_P="${MY_PN}-${MY_PV}"
+MY_P="${PN^}-XXII"
-DESCRIPTION="A chess engine suitable for beginner and intermediate players"
+DESCRIPTION="Chess engine suitable for beginner and intermediate players"
HOMEPAGE="http://phalanx.sourceforge.net/"
SRC_URI="mirror://sourceforge/phalanx/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-S="${WORKDIR}/${MY_P}"
src_compile() {
# configure is not used in the project; confs are in Makefile,
# and here we override them:
local define="-DGNUFUN" myvar
for myvar in "PBOOK" "SBOOK" "LEARN" ; do
- define="${define} -D${myvar}_DIR=\"\\\"/usr/share/${PN}\\\"\""
+ define="${define} -D${myvar}_DIR=\"\\\"${EPREFIX}/usr/share/${PN}\\\"\""
done
emake \
DEFINES="${define}" \
@@ -35,7 +32,9 @@ src_compile() {
src_install() {
dobin phalanx
+
insinto /usr/share/${PN}
doins pbook.phalanx sbook.phalanx learn.phalanx
+
einstalldocs
}