summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-09-07 17:45:39 -0500
committerAustin English <wizardedit@gentoo.org>2016-09-07 18:28:55 -0500
commite1a391c2c1fdb2ae97e191e1d39de43736da4e21 (patch)
tree87c29571bf4d039622d19ddbe1acf56b98746d1e /games-board
parentgames-board/freedoko: remove deprecated games eclass (diff)
downloadgentoo-e1a391c2c1fdb2ae97e191e1d39de43736da4e21.tar.gz
gentoo-e1a391c2c1fdb2ae97e191e1d39de43736da4e21.tar.bz2
gentoo-e1a391c2c1fdb2ae97e191e1d39de43736da4e21.zip
games-board/eboard: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
Diffstat (limited to 'games-board')
-rw-r--r--games-board/eboard/eboard-1.1.1-r2.ebuild75
-rw-r--r--games-board/eboard/files/eboard-1.1.1-as-needed.patch8
-rw-r--r--games-board/eboard/files/eboard-1.1.1-gcc44.patch4
-rw-r--r--games-board/eboard/files/eboard-1.1.1-libpng15.patch4
-rw-r--r--games-board/eboard/files/eboard-1.1.1-ovflfix.patch8
5 files changed, 87 insertions, 12 deletions
diff --git a/games-board/eboard/eboard-1.1.1-r2.ebuild b/games-board/eboard/eboard-1.1.1-r2.ebuild
new file mode 100644
index 000000000000..2b32096943a7
--- /dev/null
+++ b/games-board/eboard/eboard-1.1.1-r2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+DEB_V=${PV}-4.1
+EXTRAS1="eboard-extras-1pl2"
+EXTRAS2="eboard-extras-2"
+DESCRIPTION="chess interface for POSIX systems"
+HOMEPAGE="http://www.bergo.eng.br/eboard/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
+ mirror://sourceforge/${PN}/${EXTRAS1}.tar.gz
+ mirror://sourceforge/${PN}/${EXTRAS2}.tar.gz
+ mirror://debian/pool/main/e/eboard/${PN}_${DEB_V}.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+
+RDEPEND="
+ media-libs/libpng:0=
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${WORKDIR}"/${PN}_${DEB_V}.diff
+ "${FILESDIR}"/${P}-as-needed.patch
+ "${FILESDIR}"/${P}-gcc44.patch
+ "${FILESDIR}"/${P}-ovflfix.patch
+ "${FILESDIR}"/${P}-libpng15.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "s:(\"-O6\"):split(' ', \"${CXXFLAGS}\"):" \
+ configure || die
+}
+
+src_configure() {
+ ./configure \
+ --compiler="$(tc-getCXX)" \
+ --prefix="/usr" \
+ --data-prefix="/usr/share" \
+ --man-prefix="/usr/share/man" \
+ --extra-libs="dl" \
+ $(use_enable nls) || die # not an autoconf script
+}
+
+src_install() {
+ default
+ dodoc Documentation/*.txt
+
+ newicon icon-eboard.xpm ${PN}.xpm
+ make_desktop_entry ${PN} ${PN} ${PN}
+
+ cd "${WORKDIR}"/${EXTRAS1}
+ insinto /usr/share/${PN}
+ doins *.png *.wav
+ newins extras1.conf themeconf.extras1
+ newdoc ChangeLog Changelog.extras
+ newdoc README README.extras
+ dodoc CREDITS
+
+ cd "${WORKDIR}"/${EXTRAS2}
+ doins *.png *.wav
+ newins extras2.conf themeconf.extras2
+}
diff --git a/games-board/eboard/files/eboard-1.1.1-as-needed.patch b/games-board/eboard/files/eboard-1.1.1-as-needed.patch
index b4ec397ba967..199dd0e70a2d 100644
--- a/games-board/eboard/files/eboard-1.1.1-as-needed.patch
+++ b/games-board/eboard/files/eboard-1.1.1-as-needed.patch
@@ -1,5 +1,5 @@
---- configure.old 2009-02-03 14:46:21.000000000 +0100
-+++ configure 2009-02-03 14:48:13.000000000 +0100
+--- a/configure 2009-02-03 14:46:21.000000000 +0100
++++ b/configure 2009-02-03 14:48:13.000000000 +0100
@@ -638,7 +638,7 @@
print CONFIGMAKE "CXX = $cxx\n";
@@ -9,8 +9,8 @@
print CONFIGMAKE "prefix = \${DESTDIR}$prefix\n";
print CONFIGMAKE "bindir = \${DESTDIR}$prefix/bin\n";
---- elifekam.old 2009-02-03 14:48:43.000000000 +0100
-+++ elifekam 2009-02-03 14:48:58.000000000 +0100
+--- a/elifekam 2009-02-03 14:48:43.000000000 +0100
++++ b/elifekam 2009-02-03 14:48:58.000000000 +0100
@@ -24,7 +24,7 @@
all: eboard nls-dicts
diff --git a/games-board/eboard/files/eboard-1.1.1-gcc44.patch b/games-board/eboard/files/eboard-1.1.1-gcc44.patch
index 43a26393d4f4..60e7d81fcdb2 100644
--- a/games-board/eboard/files/eboard-1.1.1-gcc44.patch
+++ b/games-board/eboard/files/eboard-1.1.1-gcc44.patch
@@ -1,5 +1,5 @@
---- ntext.cc
-+++ ntext.cc
+--- a/ntext.cc
++++ b/ntext.cc
@@ -244,7 +244,7 @@
return;
}
diff --git a/games-board/eboard/files/eboard-1.1.1-libpng15.patch b/games-board/eboard/files/eboard-1.1.1-libpng15.patch
index 8ab283259f79..cd0ccf8b4f20 100644
--- a/games-board/eboard/files/eboard-1.1.1-libpng15.patch
+++ b/games-board/eboard/files/eboard-1.1.1-libpng15.patch
@@ -1,5 +1,5 @@
---- cimg.cc
-+++ cimg.cc
+--- a/cimg.cc
++++ b/cimg.cc
@@ -94,11 +95,11 @@
ct == PNG_COLOR_TYPE_GRAY_ALPHA)
png_set_gray_to_rgb(pngp);
diff --git a/games-board/eboard/files/eboard-1.1.1-ovflfix.patch b/games-board/eboard/files/eboard-1.1.1-ovflfix.patch
index 4a586b2b70a3..b09c4dba880f 100644
--- a/games-board/eboard/files/eboard-1.1.1-ovflfix.patch
+++ b/games-board/eboard/files/eboard-1.1.1-ovflfix.patch
@@ -1,5 +1,5 @@
---- proto_xboard.cc.old 2010-11-03 16:42:15.000000000 +0100
-+++ proto_xboard.cc 2010-11-03 16:43:14.000000000 +0100
+--- a/proto_xboard.cc 2010-11-03 16:42:15.000000000 +0100
++++ b/proto_xboard.cc 2010-11-03 16:43:14.000000000 +0100
@@ -1084,7 +1084,7 @@
snprintf(EngineCommandLine,512,"crafty bookpath=%s logpath=%s tbpath=%s",
BookPath,LogPath,LogPath);
@@ -9,8 +9,8 @@
else
strcpy(EngineRunDir,"/tmp");
---- util.cc.old 2010-11-03 16:42:24.000000000 +0100
-+++ util.cc 2010-11-03 16:43:42.000000000 +0100
+--- a/util.cc 2010-11-03 16:42:24.000000000 +0100
++++ b/util.cc 2010-11-03 16:43:42.000000000 +0100
@@ -783,7 +783,7 @@
int i,n;
char cmd[1024];