summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-09-08 18:18:26 -0500
committerAustin English <wizardedit@gentoo.org>2016-09-14 12:26:33 -0500
commiteb9c7cfba76055dc8d6f13180a1c3a46dcc45404 (patch)
tree7d54d92f326c108dbc54b39fff70a7cc288aaea1 /games-board
parentgames-board/ccgo: remove deprecated games eclass (diff)
downloadgentoo-eb9c7cfba76055dc8d6f13180a1c3a46dcc45404.tar.gz
gentoo-eb9c7cfba76055dc8d6f13180a1c3a46dcc45404.tar.bz2
gentoo-eb9c7cfba76055dc8d6f13180a1c3a46dcc45404.zip
games-board/cgoban: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
Diffstat (limited to 'games-board')
-rw-r--r--games-board/cgoban/cgoban-1.9.14-r1.ebuild45
-rw-r--r--games-board/cgoban/files/cgoban-1.9.14-cflags.patch12
2 files changed, 51 insertions, 6 deletions
diff --git a/games-board/cgoban/cgoban-1.9.14-r1.ebuild b/games-board/cgoban/cgoban-1.9.14-r1.ebuild
new file mode 100644
index 000000000000..948c254910fc
--- /dev/null
+++ b/games-board/cgoban/cgoban-1.9.14-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils autotools
+
+DESCRIPTION="A Go-frontend"
+HOMEPAGE="http://cgoban1.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cgoban1/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ || (
+ media-gfx/imagemagick
+ media-gfx/graphicsmagick[imagemagick]
+ )
+ x11-libs/libX11
+ x11-libs/libXt"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-cflags.patch
+)
+
+src_prepare() {
+ # ${P}-cflags.patch patches configure.ac, not .in:
+ mv configure.{in,ac} || die
+
+ default
+
+ cp cgoban_icon.png ${PN}.png || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ doicon ${PN}.png
+ make_desktop_entry cgoban Cgoban
+}
diff --git a/games-board/cgoban/files/cgoban-1.9.14-cflags.patch b/games-board/cgoban/files/cgoban-1.9.14-cflags.patch
index 7228b4803c95..a496dbf0602d 100644
--- a/games-board/cgoban/files/cgoban-1.9.14-cflags.patch
+++ b/games-board/cgoban/files/cgoban-1.9.14-cflags.patch
@@ -1,5 +1,5 @@
---- configure.ac.old 2012-09-03 18:34:15.358122626 +0200
-+++ configure.ac 2012-09-03 18:35:30.279156534 +0200
+--- a/configure.ac 2012-09-03 18:34:15.358122626 +0200
++++ b/configure.ac 2012-09-03 18:35:30.279156534 +0200
@@ -1,8 +1,9 @@
#for autoconf 2.1x start configure script with next three lines
@@ -12,8 +12,8 @@
#for autoconf 2.5x start configure script with next four lines
# AC_PREREQ(2.50)
---- configure.ac.old 2012-09-03 20:17:48.037549487 +0200
-+++ configure.ac 2012-09-03 20:18:00.267371203 +0200
+--- a/configure.ac 2012-09-03 20:17:48.037549487 +0200
++++ b/configure.ac 2012-09-03 20:18:00.267371203 +0200
@@ -146,7 +146,7 @@
######################################################################
@@ -23,8 +23,8 @@
AC_PREFIX_DEFAULT(/usr/games)
dayNum=`echo $date | awk '{ print $1 }'`
---- configure.ac.old 2012-09-03 20:23:29.174470309 +0200
-+++ configure.ac 2012-09-03 20:23:51.895996955 +0200
+--- a/configure.ac 2012-09-03 20:23:29.174470309 +0200
++++ b/configure.ac 2012-09-03 20:23:51.895996955 +0200
@@ -169,7 +169,6 @@
AC_MINIX
AC_PROG_CPP