summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrahmajit Das <brahmajit.xyz@gmail.com>2023-10-03 17:28:49 +0000
committerJames Le Cuirot <chewi@gentoo.org>2023-10-07 23:23:46 +0100
commitec4ac81d3dae982c3e081230505f1383c7798bd2 (patch)
tree8ea0af2f1d40cb14391ab58c88c8575f5f0c5ff3 /games-board
parentpackage.mask: Last rite dev-libs/libtubo, x11-libs/librfm, x11-misc/rodent (diff)
downloadgentoo-ec4ac81d3dae982c3e081230505f1383c7798bd2.tar.gz
gentoo-ec4ac81d3dae982c3e081230505f1383c7798bd2.tar.bz2
gentoo-ec4ac81d3dae982c3e081230505f1383c7798bd2.zip
games-board/xmahjongg: Fix C++17 does not allow register storage class
And update EAPI 7 -> 8 Closes: https://bugs.gentoo.org/895896 Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/33169 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-board')
-rw-r--r--games-board/xmahjongg/files/xmahjongg-3.7-drop-register-keyword.patch14
-rw-r--r--games-board/xmahjongg/xmahjongg-3.7-r2.ebuild36
2 files changed, 50 insertions, 0 deletions
diff --git a/games-board/xmahjongg/files/xmahjongg-3.7-drop-register-keyword.patch b/games-board/xmahjongg/files/xmahjongg-3.7-drop-register-keyword.patch
new file mode 100644
index 000000000000..6645f6fc5e33
--- /dev/null
+++ b/games-board/xmahjongg/files/xmahjongg-3.7-drop-register-keyword.patch
@@ -0,0 +1,14 @@
+Bug: https://bugs.gentoo.org/895896
+--- a/liblcdf/permstr.cc
++++ b/liblcdf/permstr.cc
+@@ -111,8 +111,8 @@ static int scatter[] = { /* map characters to random values */
+ void
+ PermString::initialize(const char* s, int length)
+ {
+- register unsigned char* m = (unsigned char*) s;
+- register unsigned char* mm;
++ unsigned char* m = (unsigned char*) s;
++ unsigned char* mm;
+
+ if (length < 0)
+ length = (s ? strlen(s) : 0);
diff --git a/games-board/xmahjongg/xmahjongg-3.7-r2.ebuild b/games-board/xmahjongg/xmahjongg-3.7-r2.ebuild
new file mode 100644
index 000000000000..f1fc4165b4da
--- /dev/null
+++ b/games-board/xmahjongg/xmahjongg-3.7-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools desktop
+
+DESCRIPTION="friendly GUI version of xmahjongg"
+HOMEPAGE="http://www.lcdf.org/xmahjongg/"
+SRC_URI="http://www.lcdf.org/xmahjongg/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-libs/libXt"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-autotools.patch
+ "${FILESDIR}"/${P}-drop-register-keyword.patch
+)
+
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ newicon share/tiles/small.gif ${PN}.gif
+ make_desktop_entry xmahjongg "Xmahjongg" /usr/share/pixmaps/${PN}.gif
+}