summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-29 10:08:03 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-29 13:24:49 +0200
commitfa1c79db4f2cf11b9c1b92fba205a8593003c3b2 (patch)
tree29495030267f4a878303a6aaec5f5da167162b70 /games-board
parentgames-board/gnugo: Drop games.eclass, format-security fix (#544362) (diff)
downloadgentoo-fa1c79db4f2cf11b9c1b92fba205a8593003c3b2.tar.gz
gentoo-fa1c79db4f2cf11b9c1b92fba205a8593003c3b2.tar.bz2
gentoo-fa1c79db4f2cf11b9c1b92fba205a8593003c3b2.zip
games-board/phalanx: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-board')
-rw-r--r--games-board/phalanx/phalanx-22-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/games-board/phalanx/phalanx-22-r1.ebuild b/games-board/phalanx/phalanx-22-r1.ebuild
new file mode 100644
index 000000000000..cb72a63812f8
--- /dev/null
+++ b/games-board/phalanx/phalanx-22-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+MY_PN="Phalanx"
+MY_PV="XXII"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="A chess engine suitable for beginner and intermediate players"
+HOMEPAGE="http://phalanx.sourceforge.net/"
+SRC_URI="mirror://sourceforge/phalanx/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ # configure is not used in the project; confs are in Makefile,
+ # and here we override them:
+ local define="-DGNUFUN" myvar
+ for myvar in "PBOOK" "SBOOK" "LEARN" ; do
+ define="${define} -D${myvar}_DIR=\"\\\"/usr/share/${PN}\\\"\""
+ done
+ emake \
+ DEFINES="${define}" \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin phalanx
+ insinto /usr/share/${PN}
+ doins pbook.phalanx sbook.phalanx learn.phalanx
+ einstalldocs
+}