summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno <hanno@gentoo.org>2016-10-15 11:04:07 +0200
committerHanno <hanno@gentoo.org>2016-10-15 11:04:07 +0200
commit16ab6dc1c21bd6b456b5acbb778fff940dd2cd46 (patch)
tree749f9b4d3c79254529e80e9c1fefd9e15b8412f1 /games-emulation/desmume
parentnet-libs/nodejs: Bump (diff)
downloadgentoo-16ab6dc1c21bd6b456b5acbb778fff940dd2cd46.tar.gz
gentoo-16ab6dc1c21bd6b456b5acbb778fff940dd2cd46.tar.bz2
gentoo-16ab6dc1c21bd6b456b5acbb778fff940dd2cd46.zip
games-emulation/desmume: Various fixes and cleanups
Bumped EAPI to 6. Removed deprecated games eclass. Added missing intltool dep (fix #576078). Fix type conversion compiler warning (patch also sent upstream). Package-Manager: portage-2.3.2
Diffstat (limited to 'games-emulation/desmume')
-rw-r--r--games-emulation/desmume/desmume-0.9.11-r1.ebuild32
-rw-r--r--games-emulation/desmume/files/desmume-0.9.11-fix-pointer-conversion-warning.diff11
2 files changed, 43 insertions, 0 deletions
diff --git a/games-emulation/desmume/desmume-0.9.11-r1.ebuild b/games-emulation/desmume/desmume-0.9.11-r1.ebuild
new file mode 100644
index 000000000000..f31a22b4a20a
--- /dev/null
+++ b/games-emulation/desmume/desmume-0.9.11-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Nintendo DS emulator"
+HOMEPAGE="http://desmume.org/"
+SRC_URI="mirror://sourceforge/desmume/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.8.0:2
+ gnome-base/libglade
+ x11-libs/gtkglext
+ virtual/opengl
+ sys-libs/zlib
+ dev-libs/zziplib
+ media-libs/libsdl[joystick,opengl,video]
+ x11-libs/agg"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-util/intltool"
+
+DOCS=( AUTHORS ChangeLog README README.LIN )
+
+# fix QA compiler warning, see
+# https://sourceforge.net/p/desmume/patches/172/
+PATCHES=( "${FILESDIR}/${P}-fix-pointer-conversion-warning.diff" )
diff --git a/games-emulation/desmume/files/desmume-0.9.11-fix-pointer-conversion-warning.diff b/games-emulation/desmume/files/desmume-0.9.11-fix-pointer-conversion-warning.diff
new file mode 100644
index 000000000000..8975085133ff
--- /dev/null
+++ b/games-emulation/desmume/files/desmume-0.9.11-fix-pointer-conversion-warning.diff
@@ -0,0 +1,11 @@
+--- a/src/path.h 2015-02-14 16:05:26.000000000 +0100
++++ b/src/path.h 2016-07-11 12:09:59.591987169 +0200
+@@ -375,7 +375,7 @@
+ else if (strchr(strftimeArgs, *p))
+ {
+ char tmp[MAX_PATH];
+- char format[] = { '%', *p, NULL };
++ char format[] = { '%', *p, '\0' };
+ strftime(tmp, MAX_PATH, format, time_struct);
+ file.append(tmp);
+ }