summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2018-07-12 01:09:06 +0300
committerTony Vroon <chainsaw@gentoo.org>2018-07-13 10:27:11 +0100
commit36e4ca67227d1ee5b89ba92a15e115ea7768cb2b (patch)
treef0f0a6be52547ac835d744eb2a39900119c48073 /games-emulation/hatari
parentgames-emulation/emutos: version bump to 0.9.9.1 (diff)
downloadgentoo-36e4ca67227d1ee5b89ba92a15e115ea7768cb2b.tar.gz
gentoo-36e4ca67227d1ee5b89ba92a15e115ea7768cb2b.tar.bz2
gentoo-36e4ca67227d1ee5b89ba92a15e115ea7768cb2b.zip
games-emulation/hatari: version bump to 2.1.0
Ebuild based on Alex Bennee's works. Closes: https://bugs.gentoo.org/651146 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'games-emulation/hatari')
-rw-r--r--games-emulation/hatari/Manifest1
-rw-r--r--games-emulation/hatari/hatari-2.1.0.ebuild76
-rw-r--r--games-emulation/hatari/metadata.xml3
3 files changed, 80 insertions, 0 deletions
diff --git a/games-emulation/hatari/Manifest b/games-emulation/hatari/Manifest
index f6267b9ecdeb..8f2de08f3877 100644
--- a/games-emulation/hatari/Manifest
+++ b/games-emulation/hatari/Manifest
@@ -1 +1,2 @@
DIST hatari-1.8.0.tar.bz2 1985358 BLAKE2B 12fc000dd04c0f0dcead0b6713837a0d4c02df5ecdab9c2d4d2d91bd4cf6f8657acf2d97649a5704b646fae4fefe0626300e297b9e8698e7b8b72854d37b7097 SHA512 498a6636eef78e85a4715e9df169d928ce97c0548145a95b41aa3aae28817b8e843de1d1390893863be05e4e9981c89236571ab2eb9239faad23b711542e4fa0
+DIST hatari-2.1.0.tar.bz2 4072778 BLAKE2B 934ab28e799d0d13c26c291005513511367eb2ddbeda0f9756c19f10fa9e6bb8e10451057fa7e0b49a30e3f562eb5f327057d324b2a92e09b1115f63132dca97 SHA512 d1fbf6e60e2df2c43d070bee6a9c1dc93c36a8ea7f75bbf2a67790840952661cee136ebccd6b2ed523ef9b7b56391e058384f2e3f46acb609bb362cac05b9753
diff --git a/games-emulation/hatari/hatari-2.1.0.ebuild b/games-emulation/hatari/hatari-2.1.0.ebuild
new file mode 100644
index 000000000000..92eba857519e
--- /dev/null
+++ b/games-emulation/hatari/hatari-2.1.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+inherit toolchain-funcs cmake-utils python-single-r1
+
+DESCRIPTION="Atari ST emulator"
+HOMEPAGE="http://hatari.tuxfamily.org/"
+SRC_URI="http://download.tuxfamily.org/hatari/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+sdl2"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ games-emulation/caps
+ sdl2? ( media-libs/libsdl2[X,sound,video] )
+ !sdl2? ( media-libs/libsdl[X,sound,video] )
+ media-libs/portaudio
+ media-libs/portmidi
+ sys-libs/readline:0=
+ media-libs/libpng:0=
+ sys-libs/zlib:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+PDEPEND="dev-python/pygtk[${PYTHON_USEDEP}]
+ >=games-emulation/emutos-0.9.9.1"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="
+You need a TOS ROM to run hatari. EmuTOS, a free TOS implementation,
+has been installed in /usr/lib*/hatari with a .img extension (there
+are several from which to choose).
+Another option is to go to http://www.atari.st/ and get a real TOS:
+http://www.atari.st/
+The first time you run hatari, you should configure it to find the
+TOS you prefer to use. Be sure to save your settings.
+"
+
+DOCS="readme.txt doc/*.txt"
+HTML_DOCS="doc/"
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ sed -i -e '/Encoding/d' ./python-ui/hatariui.desktop || die
+ sed -i -e "s/python/${EPYTHON}/" tools/atari-hd-image.sh || die
+ sed -i -e "s#@DOCDIR@#/usr/share/doc/${PF}/html/#" python-ui/uihelpers.py || die
+}
+
+src_configure() {
+ mycmakeargs=(
+ "-DDOCDIR=/usr/share/doc/${PF}"
+ "-DENABLE_SDL2=$(usex sdl2)"
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ python_fix_shebang "${ED%/}"/usr/share/hatari/{hatariui,hconsole}/
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
diff --git a/games-emulation/hatari/metadata.xml b/games-emulation/hatari/metadata.xml
index 78274e0fa550..d4511e749d48 100644
--- a/games-emulation/hatari/metadata.xml
+++ b/games-emulation/hatari/metadata.xml
@@ -5,4 +5,7 @@
<email>games@gentoo.org</email>
<name>Gentoo Games Project</name>
</maintainer>
+<use>
+ <flag name="sdl2">Use libsdl2 instead of libsdl</flag>
+</use>
</pkgmetadata>