summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2017-12-22 16:22:27 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-23 14:09:48 +0100
commit518abc5a7a196d945d2c6ca4bd9cbe846735fa34 (patch)
treeaa34e637e8d6f8f25e48274cc43165171497c49f /games-emulation/higan
parentgames-emulation/fbzx: remove unused patches (diff)
downloadgentoo-518abc5a7a196d945d2c6ca4bd9cbe846735fa34.tar.gz
gentoo-518abc5a7a196d945d2c6ca4bd9cbe846735fa34.tar.bz2
gentoo-518abc5a7a196d945d2c6ca4bd9cbe846735fa34.zip
games-emulation/higan: remove unused patch
Diffstat (limited to 'games-emulation/higan')
-rw-r--r--games-emulation/higan/files/higan-094-QA.patch90
1 files changed, 0 insertions, 90 deletions
diff --git a/games-emulation/higan/files/higan-094-QA.patch b/games-emulation/higan/files/higan-094-QA.patch
deleted file mode 100644
index 69aaedf3d3de..000000000000
--- a/games-emulation/higan/files/higan-094-QA.patch
+++ /dev/null
@@ -1,90 +0,0 @@
-From: Julian Ospald <hasufell@gentoo.org>
-Date: Sun Jun 9 10:23:38 UTC 2013
-Subject:
-
---- a/Makefile
-+++ b/Makefile
-@@ -13,8 +13,8 @@
- # console := true
-
- # compiler
--flags += -I. -O3 -fomit-frame-pointer
--link +=
-+flags += -I.
-+link += $(LDFLAGS)
- objects := libco
-
- # profile-guided optimization mode
-@@ -41,14 +41,12 @@
- endif
- link += -s -mthreads -luuid -lkernel32 -luser32 -lgdi32 -lcomctl32 -lcomdlg32 -lshell32 -lole32 -lws2_32
- link += -Wl,-enable-auto-import -Wl,-enable-runtime-pseudo-reloc
--else ifeq ($(platform),macosx)
-- flags += -march=native
- else ifeq ($(platform),linux)
-- flags += -march=native
-- link += -s -Wl,-export-dynamic -lX11 -lXext -ldl
-+ flags +=
-+ link += -Wl,-export-dynamic -lX11 -lXext -ldl
- else ifeq ($(platform),bsd)
-- flags += -march=native
-- link += -s -Wl,-export-dynamic -lX11 -lXext
-+ flags +=
-+ link += -Wl,-export-dynamic -lX11 -lXext
- else
- $(error unsupported platform.)
- endif
-@@ -59,9 +57,9 @@
- compile = \
- $(strip \
- $(if $(filter %.c,$<), \
-- $(compiler) $(cflags) $(flags) $1 -c $< -o $@, \
-+ $(compiler) $(cflags) $(flags) $(CFLAGS) $1 -c $< -o $@, \
- $(if $(filter %.cpp,$<), \
-- $(compiler) $(cppflags) $(flags) $1 -c $< -o $@ \
-+ $(compiler) $(cppflags) $(flags) $(CXXFLAGS) $1 -c $< -o $@ \
- ) \
- ) \
- )
---- a/target-ethos/Makefile
-+++ b/target-ethos/Makefile
-@@ -55,10 +55,10 @@
- obj/ui-tools.o: $(ui)/tools/tools.cpp $(call rwildcard,$(ui)/)
-
- obj/ruby.o: ruby/ruby.cpp $(call rwildcard,ruby/*)
-- $(compiler) $(rubyflags) -c $< -o $@
-+ $(compiler) $(rubyflags) $(CXXFLAGS) -c $< -o $@
-
- obj/phoenix.o: phoenix/phoenix.cpp $(call rwildcard,phoenix/*)
-- $(compiler) $(phoenixflags) -c $< -o $@
-+ $(compiler) $(phoenixflags) $(CXXFLAGS) -c $< -o $@
-
- obj/resource.o: $(ui)/resource.rc
- ifeq ($(arch),win32)
-@@ -82,7 +82,7 @@
- sips -s format icns data/higan.png --out out/$(name).app/Contents/Resources/higan.icns
- $(strip $(compiler) -o out/$(name).app/Contents/MacOS/$(name) $(objects) $(link))
- else
-- $(strip $(compiler) -o out/$(name) $(objects) $(link))
-+ $(strip $(CXX) $(CXXFLAGS) -o out/$(name) $(objects) $(link))
- endif
-
- resource:
---- a/nall/Makefile
-+++ b/nall/Makefile
-@@ -53,11 +53,11 @@
- link :=
- endif
-
-- cflags := -x c -std=c99
-- objcflags := -x objective-c -std=c99
-- cppflags := -x c++ -std=c++11
-- objcppflags := -x objective-c++ -std=c++11
- endif
-+cflags := -x c -std=c99
-+objcflags := -x objective-c -std=c99
-+cppflags := -x c++ -std=c++11
-+objcppflags := -x objective-c++ -std=c++11
-
- # cross-compilation support
- ifeq ($(arch),x86)