summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-03-13 02:00:52 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-03-13 02:04:56 +0100
commita5a2748cc895020a5d5582192c69874b7fde795d (patch)
tree3f293c3196da9368508e07319f9464672c299eae /games-emulation/melonds
parentdev-libs/teakra: new package; add 20220224 (diff)
downloadgentoo-a5a2748cc895020a5d5582192c69874b7fde795d.tar.gz
gentoo-a5a2748cc895020a5d5582192c69874b7fde795d.tar.bz2
gentoo-a5a2748cc895020a5d5582192c69874b7fde795d.zip
games-emulation/melonds: use system teakra
Closes: https://bugs.gentoo.org/834984 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'games-emulation/melonds')
-rw-r--r--games-emulation/melonds/files/melonds-system-teakra.patch23
-rw-r--r--games-emulation/melonds/melonds-0.9.3-r2.ebuild (renamed from games-emulation/melonds/melonds-0.9.3-r1.ebuild)13
-rw-r--r--games-emulation/melonds/melonds-0.9.4_p1-r1.ebuild (renamed from games-emulation/melonds/melonds-0.9.4_p1.ebuild)13
-rw-r--r--games-emulation/melonds/melonds-9999.ebuild13
4 files changed, 38 insertions, 24 deletions
diff --git a/games-emulation/melonds/files/melonds-system-teakra.patch b/games-emulation/melonds/files/melonds-system-teakra.patch
new file mode 100644
index 000000000000..b59c31e4ba9a
--- /dev/null
+++ b/games-emulation/melonds/files/melonds-system-teakra.patch
@@ -0,0 +1,23 @@
+index 7288b54..6525f11 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -110,7 +110,6 @@ if (ENABLE_JIT)
+ endif()
+ endif()
+
+-add_subdirectory(teakra EXCLUDE_FROM_ALL)
+ target_link_libraries(core teakra)
+
+
+index c889aff..a6339d9 100644
+--- a/src/DSi_DSP.cpp
++++ b/src/DSi_DSP.cpp
+@@ -16,7 +16,7 @@
+ with melonDS. If not, see http://www.gnu.org/licenses/.
+ */
+
+-#include "teakra/include/teakra/teakra.h"
++#include "teakra/teakra.h"
+
+ #include "DSi.h"
+ #include "DSi_DSP.h"
diff --git a/games-emulation/melonds/melonds-0.9.3-r1.ebuild b/games-emulation/melonds/melonds-0.9.3-r2.ebuild
index 77ff242ab004..0cde97c7b287 100644
--- a/games-emulation/melonds/melonds-0.9.3-r1.ebuild
+++ b/games-emulation/melonds/melonds-0.9.3-r2.ebuild
@@ -1,9 +1,6 @@
# Copyright 2019-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# NOTICE:
-# melonds bundles teakra, its upstream haven't had a release since 2020
-
EAPI=8
MY_PN="melonDS"
@@ -32,6 +29,7 @@ SLOT="0"
DEPEND="
app-arch/libarchive
+ dev-libs/teakra
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtnetwork:5
@@ -55,7 +53,11 @@ DOC_CONTENTS="You need the following files in order to run melonDS:
Place them in ~/.config/melonDS
Those files can be found somewhere on the Internet ;-)"
+PATCHES=( "${FILESDIR}"/melonds-system-teakra.patch )
+
src_prepare() {
+ rm -r ./src/teakra || die
+
cmake_src_prepare
}
@@ -73,16 +75,11 @@ src_compile() {
}
src_install() {
- # install teakra
- dolib.so "${BUILD_DIR}/src/teakra/src/libteakra.so"
-
cmake_src_install
-
readme.gentoo_create_doc
}
pkg_postinst() {
xdg_pkg_postinst
-
readme.gentoo_print_elog
}
diff --git a/games-emulation/melonds/melonds-0.9.4_p1.ebuild b/games-emulation/melonds/melonds-0.9.4_p1-r1.ebuild
index d27c6c66a307..706876b372f2 100644
--- a/games-emulation/melonds/melonds-0.9.4_p1.ebuild
+++ b/games-emulation/melonds/melonds-0.9.4_p1-r1.ebuild
@@ -1,9 +1,6 @@
# Copyright 2019-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# NOTICE:
-# melonds bundles teakra, its upstream haven't had a release since 2020
-
EAPI=8
MY_PN="melonDS"
@@ -32,6 +29,7 @@ SLOT="0"
DEPEND="
app-arch/libarchive
+ dev-libs/teakra
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtnetwork:5
@@ -55,7 +53,11 @@ DOC_CONTENTS="You need the following files in order to run melonDS:
Place them in ~/.config/melonDS
Those files can be found somewhere on the Internet ;-)"
+PATCHES=( "${FILESDIR}"/melonds-system-teakra.patch )
+
src_prepare() {
+ rm -r ./src/teakra || die
+
cmake_src_prepare
}
@@ -73,16 +75,11 @@ src_compile() {
}
src_install() {
- # install teakra
- dolib.so "${BUILD_DIR}/src/teakra/src/libteakra.so"
-
cmake_src_install
-
readme.gentoo_create_doc
}
pkg_postinst() {
xdg_pkg_postinst
-
readme.gentoo_print_elog
}
diff --git a/games-emulation/melonds/melonds-9999.ebuild b/games-emulation/melonds/melonds-9999.ebuild
index 77ff242ab004..0cde97c7b287 100644
--- a/games-emulation/melonds/melonds-9999.ebuild
+++ b/games-emulation/melonds/melonds-9999.ebuild
@@ -1,9 +1,6 @@
# Copyright 2019-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# NOTICE:
-# melonds bundles teakra, its upstream haven't had a release since 2020
-
EAPI=8
MY_PN="melonDS"
@@ -32,6 +29,7 @@ SLOT="0"
DEPEND="
app-arch/libarchive
+ dev-libs/teakra
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtnetwork:5
@@ -55,7 +53,11 @@ DOC_CONTENTS="You need the following files in order to run melonDS:
Place them in ~/.config/melonDS
Those files can be found somewhere on the Internet ;-)"
+PATCHES=( "${FILESDIR}"/melonds-system-teakra.patch )
+
src_prepare() {
+ rm -r ./src/teakra || die
+
cmake_src_prepare
}
@@ -73,16 +75,11 @@ src_compile() {
}
src_install() {
- # install teakra
- dolib.so "${BUILD_DIR}/src/teakra/src/libteakra.so"
-
cmake_src_install
-
readme.gentoo_create_doc
}
pkg_postinst() {
xdg_pkg_postinst
-
readme.gentoo_print_elog
}