summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-02-01 04:08:53 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-02-01 04:11:01 +0100
commite34e279d5d5dee9ab8661490a2ab6b881be0d9e7 (patch)
treec857e23f6a03ca6a2c680af8a722484aa9c3f811 /games-emulation/mgba
parentgames-emulation/mgba: Fixed build with USE="qt -sdl" (diff)
downloadgentoo-e34e279d5d5dee9ab8661490a2ab6b881be0d9e7.tar.gz
gentoo-e34e279d5d5dee9ab8661490a2ab6b881be0d9e7.tar.bz2
gentoo-e34e279d5d5dee9ab8661490a2ab6b881be0d9e7.zip
games-emulation/mgba: Added "discord" USE flag
Thanks-to: Esteve Varela Colominas <esteve.varela@gmail.com> Closes: https://bugs.gentoo.org/707576 Package-Manager: Portage-2.3.86, Repoman-2.3.20 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'games-emulation/mgba')
-rw-r--r--games-emulation/mgba/metadata.xml1
-rw-r--r--games-emulation/mgba/mgba-0.8.0.ebuild3
-rw-r--r--games-emulation/mgba/mgba-9999.ebuild3
3 files changed, 5 insertions, 2 deletions
diff --git a/games-emulation/mgba/metadata.xml b/games-emulation/mgba/metadata.xml
index ef2909f744e8..d65ffa04f67d 100644
--- a/games-emulation/mgba/metadata.xml
+++ b/games-emulation/mgba/metadata.xml
@@ -6,6 +6,7 @@
<name>Lars Wendler</name>
</maintainer>
<use>
+ <flag name="discord">Enable Discord RPC support</flag>
<flag name="elf">Enable the use of elf utils via <pkg>dev-libs/elfutils</pkg></flag>
</use>
<upstream>
diff --git a/games-emulation/mgba/mgba-0.8.0.ebuild b/games-emulation/mgba/mgba-0.8.0.ebuild
index cc49129ae05f..15a46f8a7006 100644
--- a/games-emulation/mgba/mgba-0.8.0.ebuild
+++ b/games-emulation/mgba/mgba-0.8.0.ebuild
@@ -19,7 +19,7 @@ else
fi
LICENSE="MPL-2.0"
SLOT="0"
-IUSE="debug elf ffmpeg libav opengl qt5 +sdl sqlite"
+IUSE="debug discord elf ffmpeg libav opengl qt5 +sdl sqlite"
REQUIRED_USE="|| ( qt5 sdl )
qt5? ( opengl )"
@@ -72,6 +72,7 @@ src_configure() {
-DM_CORE_GB=ON
-DM_CORE_GBA=ON
-DUSE_DEBUGGERS="$(usex debug)"
+ -DUSE_DISCORD_RPC="$(usex discord)"
-DUSE_EDITLINE="$(usex debug)"
-DUSE_ELF="$(usex elf)"
-DUSE_EPOXY=OFF
diff --git a/games-emulation/mgba/mgba-9999.ebuild b/games-emulation/mgba/mgba-9999.ebuild
index 3543aa68ebf8..1200fa57ed49 100644
--- a/games-emulation/mgba/mgba-9999.ebuild
+++ b/games-emulation/mgba/mgba-9999.ebuild
@@ -19,7 +19,7 @@ else
fi
LICENSE="MPL-2.0"
SLOT="0"
-IUSE="debug elf ffmpeg libav opengl qt5 +sdl sqlite"
+IUSE="debug discord elf ffmpeg libav opengl qt5 +sdl sqlite"
REQUIRED_USE="|| ( qt5 sdl )
qt5? ( opengl )"
@@ -68,6 +68,7 @@ src_configure() {
-DM_CORE_GB=ON
-DM_CORE_GBA=ON
-DUSE_DEBUGGERS="$(usex debug)"
+ -DUSE_DISCORD_RPC="$(usex discord)"
-DUSE_EDITLINE="$(usex debug)"
-DUSE_ELF="$(usex elf)"
-DUSE_EPOXY=OFF