summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-01-11 05:37:42 -0500
committerIonen Wolkens <ionen@gentoo.org>2023-01-11 06:25:31 -0500
commitcb02ebec944893f1b016a3844a0e7de2a9db4908 (patch)
tree1803af791e18b8a815ce94448455b1976072292a /games-emulation/nestopia
parentgames-emulation/nestopia: add 1.52.0 (diff)
downloadgentoo-cb02ebec944893f1b016a3844a0e7de2a9db4908.tar.gz
gentoo-cb02ebec944893f1b016a3844a0e7de2a9db4908.tar.bz2
gentoo-cb02ebec944893f1b016a3844a0e7de2a9db4908.zip
games-emulation/nestopia: sync live
This been in 1.51.1 for a while and unfortunately is still needed in 1.52.0. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-emulation/nestopia')
-rw-r--r--games-emulation/nestopia/nestopia-9999.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/games-emulation/nestopia/nestopia-9999.ebuild b/games-emulation/nestopia/nestopia-9999.ebuild
index c6bdbe0d6fb8..646a1b125a96 100644
--- a/games-emulation/nestopia/nestopia-9999.ebuild
+++ b/games-emulation/nestopia/nestopia-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit autotools xdg
+inherit autotools flag-o-matic xdg
DESCRIPTION="Portable Nintendo Entertainment System emulator written in C++"
HOMEPAGE="http://0ldsk00l.ca/nestopia/"
@@ -38,5 +38,8 @@ src_prepare() {
}
src_configure() {
+ # silence the narrowing warnings on clang (#830469)
+ append-cxxflags -Wno-narrowing
+
econf $(use_enable doc)
}