summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-01-01 00:21:12 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-01-01 03:13:04 -0500
commit20799a02b1ce02cd457cda4463c0bc5592d89d64 (patch)
tree452053c46ba7459e27c676990076367df23d77b3 /games-emulation/pcsx2
parentdev-cpp/rapidyaml: initial import, version 0.3.0 (diff)
downloadgentoo-20799a02b1ce02cd457cda4463c0bc5592d89d64.tar.gz
gentoo-20799a02b1ce02cd457cda4463c0bc5592d89d64.tar.bz2
gentoo-20799a02b1ce02cd457cda4463c0bc5592d89d64.zip
games-emulation/pcsx2: update live ebuild
ebuild could use more attention before an eventual release (unbundling, re-checking options/deps, wayland, making tests run), but this is just quickfixes to at least let it build. Two new dependencies: * rapidyaml(new package): replaces yaml-cpp * cubeb(submodule): replaces portaudio pcsx2 isn't currently wired to use system's cubeb and it also isn't packaged, so use submodule for now -- but it'd be good to package it eventually given other packages like yuzu (which could be nice to have in ::gentoo eventually) can use it as well. An ebuild would also help for more proper backend support, but for now hard depend on pulseaudio given it's the only one it links with. The cubeb introduction in PCSX2 is very recent so it may also be good to wait and see. Also update licenses for cubeb(ISC) and libchdr(BSD). /usr/bin/PCSX2 was also renamed to pcsx2, update ebuild to match. Removed QA_* instead of updating them given the messages do not seem to trigger anymore. Runtime wasn't really tested, could be issues -- but it'd be expected with upstream changing things around. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-emulation/pcsx2')
-rw-r--r--games-emulation/pcsx2/pcsx2-9999.ebuild40
1 files changed, 19 insertions, 21 deletions
diff --git a/games-emulation/pcsx2/pcsx2-9999.ebuild b/games-emulation/pcsx2/pcsx2-9999.ebuild
index 6c56bf44c0de..c80113c34e62 100644
--- a/games-emulation/pcsx2/pcsx2-9999.ebuild
+++ b/games-emulation/pcsx2/pcsx2-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -9,9 +9,13 @@ inherit cmake fcaps flag-o-matic git-r3 toolchain-funcs wxwidgets
DESCRIPTION="A PlayStation 2 emulator"
HOMEPAGE="https://pcsx2.net/"
EGIT_REPO_URI="https://github.com/PCSX2/${PN}.git"
-EGIT_SUBMODULES=( 3rdparty/libchdr/libchdr )
+EGIT_SUBMODULES=(
+ # TODO: unbundle
+ 3rdparty/cubeb/cubeb
+ 3rdparty/libchdr/libchdr
+)
-LICENSE="GPL-3"
+LICENSE="GPL-3 BSD ISC"
SLOT="0"
KEYWORDS=""
IUSE="test"
@@ -19,33 +23,37 @@ IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="
- app-arch/bzip2
app-arch/xz-utils
- dev-cpp/yaml-cpp:=
+ dev-cpp/rapidyaml:=
+ dev-libs/glib:2
dev-libs/libaio
>=dev-libs/libfmt-7.1.3:=
dev-libs/libxml2:2
media-libs/alsa-lib
+ media-libs/freetype
+ media-libs/libglvnd
media-libs/libpng:=
media-libs/libsamplerate
media-libs/libsdl2[haptic,joystick,sound]
- media-libs/libsoundtouch
- media-libs/portaudio
+ media-libs/libsoundtouch:=
+ media-sound/pulseaudio
net-libs/libpcap
sys-libs/zlib
- virtual/libudev
- virtual/opengl
+ virtual/libudev:=
+ x11-libs/gdk-pixbuf:2
x11-libs/gtk+:3
x11-libs/libICE
x11-libs/libX11
x11-libs/libXext
x11-libs/wxGTK:${WX_GTK_VER}[X]
"
-DEPEND="${RDEPEND}"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto"
BDEPEND="test? ( dev-cpp/gtest )"
FILECAPS=(
- -m 755 "CAP_NET_RAW+eip CAP_NET_ADMIN+eip" usr/bin/PCSX2
+ -m 755 "CAP_NET_RAW+eip CAP_NET_ADMIN+eip" usr/bin/pcsx2
)
pkg_setup() {
@@ -73,7 +81,6 @@ src_configure() {
-DDISABLE_PCSX2_WRAPPER=TRUE
-DDISABLE_SETCAP=TRUE
-DENABLE_TESTS="$(usex test)"
- -DOPTIMIZATION_FLAG=
-DPACKAGE_MODE=TRUE
-DXDG_STD=TRUE
@@ -87,12 +94,3 @@ src_configure() {
setup-wxwidgets
cmake_src_configure
}
-
-src_install() {
- # Upstream issues:
- # https://github.com/PCSX2/pcsx2/issues/417
- # https://github.com/PCSX2/pcsx2/issues/3077
- QA_EXECSTACK="usr/bin/PCSX2"
- QA_TEXTRELS="usr/$(get_libdir)/PCSX2/* usr/bin/PCSX2"
- cmake_src_install
-}