summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobinDX <robin9800xt@gmail.com>2016-01-19 19:10:43 +0800
committerRobinDX <robin9800xt@gmail.com>2016-01-19 19:11:15 +0800
commit32516e83e04f3ad49438df03b9e0642484a0e262 (patch)
tree168eb53b0f99247b7c8422e9e20081f06b479567 /games-emulation/ppsspp/ppsspp-9999.ebuild
parentRevert "x11-libs/gtk+: subslot gtk+:3" (diff)
downloadgentoo-32516e83e04f3ad49438df03b9e0642484a0e262.tar.gz
gentoo-32516e83e04f3ad49438df03b9e0642484a0e262.tar.bz2
gentoo-32516e83e04f3ad49438df03b9e0642484a0e262.zip
games-emulation/ppsspp:new ebuild
Diffstat (limited to 'games-emulation/ppsspp/ppsspp-9999.ebuild')
-rw-r--r--games-emulation/ppsspp/ppsspp-9999.ebuild92
1 files changed, 92 insertions, 0 deletions
diff --git a/games-emulation/ppsspp/ppsspp-9999.ebuild b/games-emulation/ppsspp/ppsspp-9999.ebuild
new file mode 100644
index 000000000000..742b19cc1a76
--- /dev/null
+++ b/games-emulation/ppsspp/ppsspp-9999.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit eutils cmake-utils qt4-r2 git-r3
+
+DESCRIPTION="A PSP emulator for Android, Windows, Mac, Linux and Blackberry 10, written in C++."
+HOMEPAGE="http://www.ppsspp.org/"
+EGIT_REPO_URI="git://github.com/hrydgard/ppsspp.git"
+#EGIT_COMMIT="v${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="qt4 +sdl"
+REQUIRED_USE="
+ ?? ( qt4 sdl )
+"
+
+RDEPEND=""
+DEPEND="sys-libs/zlib
+ sdl? ( media-libs/libsdl )
+ sdl? ( media-libs/libsdl2 )
+ sdl? ( dev-util/cmake )
+ qt4? ( dev-qt/qtcore:4 )
+ qt4? ( dev-qt/qtgui:4 )
+ qt4? ( dev-qt/qtmultimedia:4 )
+ qt4? ( dev-qt/qtopengl:4 )
+ qt4? ( dev-qt/qtsvg:4 )
+ qt4? ( dev-qt/qt-mobility[multimedia] )"
+
+src_unpack() {
+ git-r3_fetch
+ git-r3_checkout
+ if use qt4 ; then
+ cd "${WORKDIR}"/"${P}"/Qt
+ qt4-r2_src_unpack
+ fi
+ cp /usr/portage/distfiles/ppsspp-icon.png "${WORKDIR}"/"${P}"/
+}
+
+src_prepare() {
+ epatch "$FILESDIR"/ppsspp-cmake.patch
+ epatch "$FILESDIR"/ppsspp-ffmpeg-x86_64.patch
+ epatch "$FILESDIR"/ppsspp-ffmpeg-x86.patch
+ epatch "$FILESDIR"/ppsspp-qt.patch
+ if use qt4 ; then
+ cd "${WORKDIR}"/"${P}"/Qt
+ qt4-r2_src_prepare
+ else
+ cmake-utils_src_prepare
+ fi
+}
+
+src_configure() {
+ if use qt4 ; then
+ cd "${WORKDIR}"/"${P}"/Qt
+ qt4-r2_src_configure
+ eqmake4 "${WORKDIR}"/"${P}"/Qt/PPSSPPQt.pro
+ else
+ cmake-utils_src_configure
+ fi
+}
+
+src_compile() {
+ if use qt4 ; then
+ cd "${WORKDIR}"/"${P}"/Qt
+ qt4-r2_src_compile
+ else
+ cmake-utils_src_compile
+ fi
+}
+
+src_install() {
+ if use qt4 ; then
+ exeinto /usr/games/bin
+ newexe "${WORKDIR}"/"${P}"/Qt/ppsspp ppsspp
+ else
+ /usr/games
+ dobin "${FILESDIR}"/ppsspp
+ exeinto /usr/share/games/"${PN}"
+ doexe "${WORKDIR}"/"${P}"_build/PPSSPPSDL
+ insinto /usr/share/games/"${PN}"
+ doins -r "${WORKDIR}"/"${P}"_build/assets
+ doins -r "${WORKDIR}"/"${P}"/lang
+ fi
+ insinto /usr/share/icons/
+ newins "${WORKDIR}"/"${P}"/source_assets/image/icon_regular_72.png ppsspp-icon.png
+ domenu "${FILESDIR}"/ppsspp.desktop
+}