summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobinDX <robin9800xt@gmail.com>2016-02-21 11:02:36 +0800
committerRobinDX <robin9800xt@gmail.com>2016-02-21 11:06:10 +0800
commit12a60de74952677848a9e98045b1ee38c566a672 (patch)
tree309b1661fb11ae25ecca6e823905fe786016a1db /games-emulation/ppsspp
parentmail-filter/rmilter: remove old versions (diff)
downloadgentoo-12a60de74952677848a9e98045b1ee38c566a672.tar.gz
gentoo-12a60de74952677848a9e98045b1ee38c566a672.tar.bz2
gentoo-12a60de74952677848a9e98045b1ee38c566a672.zip
games-emulation/ppsspp: version bump
Diffstat (limited to 'games-emulation/ppsspp')
-rw-r--r--games-emulation/ppsspp/ppsspp-1.2.1.ebuild129
-rw-r--r--games-emulation/ppsspp/ppsspp-9999.ebuild7
2 files changed, 131 insertions, 5 deletions
diff --git a/games-emulation/ppsspp/ppsspp-1.2.1.ebuild b/games-emulation/ppsspp/ppsspp-1.2.1.ebuild
new file mode 100644
index 000000000000..6d080208e6ec
--- /dev/null
+++ b/games-emulation/ppsspp/ppsspp-1.2.1.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils cmake-utils qt4-r2 git-r3
+
+DESCRIPTION="A PSP emulator written in C++."
+HOMEPAGE="http://www.ppsspp.org/"
+EGIT_REPO_URI="git://github.com/hrydgard/${PN}.git"
+EGIT_COMMIT="v${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="qt4 qt5 +sdl"
+REQUIRED_USE="
+ ?? ( qt4 qt5 sdl )
+"
+
+RDEPEND=""
+
+DEPEND="
+ sys-libs/zlib
+ sdl? (
+ dev-util/cmake
+ media-libs/libsdl
+ media-libs/libsdl2
+ )
+ qt4? (
+ dev-qt/qtsvg:4
+ dev-qt/qtgui:4
+ dev-qt/qtcore:4
+ dev-qt/qtopengl:4
+ dev-qt/qtmultimedia:4
+ dev-qt/qt-mobility[multimedia]
+ )
+ qt5? (
+ dev-qt/qtsvg:5
+ dev-qt/qtgui:5
+ dev-qt/qtcore:5
+ dev-qt/qtopengl:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtwidgets:5
+ dev-qt/qt-mobility[multimedia]
+ )
+"
+
+src_unpack() {
+ git-r3_fetch
+ git-r3_checkout
+ if use qt4 ; then
+ cd "${WORKDIR}"/"${P}"/Qt || die
+ qt4-r2_src_unpack
+ elif use qt5 ; then
+ cd "${WORKDIR}"/"${P}"/Qt || die
+ qt4-r2_src_unpack
+ fi
+}
+
+src_prepare() {
+ sed -i -e "s#-O3#-O2#g;" "${S}"/CMakeLists.txt || die
+ sed -i -e "s#-O3#-O2#g;" "${S}"/Qt/Settings.pri || die
+ sed -i -e "s#-O3#-O2#g;" "${S}"/ffmpeg/linux_*.sh || die
+
+ if use qt4 ; then
+ cd "${WORKDIR}"/"${P}"/Qt || die
+ qt4-r2_src_prepare
+ elif use qt5 ; then
+ cd "${WORKDIR}"/"${P}"/Qt || die
+ qt4-r2_src_prepare
+ else
+ cmake-utils_src_prepare
+ fi
+}
+
+src_configure() {
+ if use qt4 ; then
+ cd "${WORKDIR}"/"${P}"/Qt || die
+ qt4-r2_src_configure
+ eqmake4 "${WORKDIR}"/"${P}"/Qt/PPSSPPQt.pro
+ elif use qt5 ; then
+ cd "${WORKDIR}"/"${P}"/Qt || die
+ qt4-r2_src_configure
+ eqmake5 "${WORKDIR}"/"${P}"/Qt/PPSSPPQt.pro
+ else
+ cmake-utils_src_configure
+ fi
+}
+
+src_compile() {
+ if use qt4 ; then
+ cd "${WORKDIR}"/"${P}"/Qt || die
+ qt4-r2_src_compile
+ elif use qt5 ; then
+ cd "${WORKDIR}"/"${P}"/Qt || die
+ qt4-r2_src_compile
+ else
+ cmake-utils_src_compile
+ fi
+}
+
+src_install() {
+ if use qt4 ; then
+ exeinto /usr/games/bin
+ newexe "${WORKDIR}"/"${P}"/Qt/ppsspp ppsspp
+ elif use qt5 ; then
+ exeinto /usr/games/bin
+ newexe "${WORKDIR}"/"${P}"/Qt/ppsspp ppsspp
+ else
+ exeinto /usr/games
+ dobin "${FILESDIR}"/ppsspp
+ exeinto /usr/share/games/"${PN}"
+ doexe "${WORKDIR}"/"${P}"_build/PPSSPPSDL
+ insinto /usr/share/games/"${PN}"
+ doins -r "${WORKDIR}"/"${P}"_build/assets
+ doins -r "${WORKDIR}"/"${P}"/lang
+ fi
+ insinto /usr/share/icons/
+ newins "${WORKDIR}"/"${P}"/source_assets/image/icon_regular_72.png ppsspp-icon.png
+ domenu "${FILESDIR}"/ppsspp.desktop
+}
+
+pkg_postinst() {
+ elog "Remember, in order to play games, you have to "
+ elog "be in the 'games' group. "
+ elog "Just run 'gpasswd -a <USER> games', then have <USER> re-login. "
+}
diff --git a/games-emulation/ppsspp/ppsspp-9999.ebuild b/games-emulation/ppsspp/ppsspp-9999.ebuild
index a3d3bccdde5d..64e75baaa156 100644
--- a/games-emulation/ppsspp/ppsspp-9999.ebuild
+++ b/games-emulation/ppsspp/ppsspp-9999.ebuild
@@ -59,12 +59,9 @@ src_unpack() {
}
src_prepare() {
- # Bug 574000
sed -i -e "s#-O3#-O2#g;" "${S}"/CMakeLists.txt || die
-
- epatch "$FILESDIR"/ppsspp-ffmpeg-x86_64.patch
- epatch "$FILESDIR"/ppsspp-ffmpeg-x86.patch
- epatch "$FILESDIR"/ppsspp-qt.patch
+ sed -i -e "s#-O3#-O2#g;" "${S}"/Qt/Settings.pri || die
+ sed -i -e "s#-O3#-O2#g;" "${S}"/ffmpeg/linux_*.sh || die
if use qt4 ; then
cd "${WORKDIR}"/"${P}"/Qt || die