summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-09-16 12:27:18 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-09-16 13:23:02 +0200
commit5ba26fd491fabad9dc0557223c1522d0915be009 (patch)
treec0775727c6dfda4bfbc3a77236b4d1c4f47bab05 /games-emulation/ppsspp
parentcmake-utils.eclass: Move CMAKE_USER_MAKE_RULES_OVERRIDE to gentoo config (diff)
downloadgentoo-5ba26fd491fabad9dc0557223c1522d0915be009.tar.gz
gentoo-5ba26fd491fabad9dc0557223c1522d0915be009.tar.bz2
gentoo-5ba26fd491fabad9dc0557223c1522d0915be009.zip
games-emulation/ppsspp: Fix build with ffmpeg-4
Closes: https://bugs.gentoo.org/666168 Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'games-emulation/ppsspp')
-rw-r--r--games-emulation/ppsspp/files/ppsspp-1.5.4-ffmpeg-4.patch34
-rw-r--r--games-emulation/ppsspp/ppsspp-1.5.4-r2.ebuild1
2 files changed, 35 insertions, 0 deletions
diff --git a/games-emulation/ppsspp/files/ppsspp-1.5.4-ffmpeg-4.patch b/games-emulation/ppsspp/files/ppsspp-1.5.4-ffmpeg-4.patch
new file mode 100644
index 000000000000..d738d4bc56c3
--- /dev/null
+++ b/games-emulation/ppsspp/files/ppsspp-1.5.4-ffmpeg-4.patch
@@ -0,0 +1,34 @@
+From 70c54a7d1ab15c0cf84a205b944db7e0339242e0 Mon Sep 17 00:00:00 2001
+From: Greg V <greg@unrelenting.technology>
+Date: Sat, 21 Apr 2018 16:44:45 +0300
+Subject: [PATCH] Fix build with ffmpeg 4.0
+
+---
+ Core/HLE/sceMpeg.cpp | 11 +++++++----
+ 1 file changed, 7 insertions(+), 4 deletions(-)
+
+diff --git a/Core/HLE/sceMpeg.cpp b/Core/HLE/sceMpeg.cpp
+index 592320515e..ae309d7b2e 100644
+--- a/Core/HLE/sceMpeg.cpp
++++ b/Core/HLE/sceMpeg.cpp
+@@ -884,13 +884,16 @@ class H264Frames{
+ }
+ };
+ #ifndef USE_FFMPEG
+-#define FF_INPUT_BUFFER_PADDING_SIZE 16
++#define AV_INPUT_BUFFER_PADDING_SIZE 16
++#endif
++#ifndef AV_INPUT_BUFFER_PADDING_SIZE
++#define AV_INPUT_BUFFER_PADDING_SIZE FF_INPUT_BUFFER_PADDING_SIZE
+ #endif
+ void addpadding(){
+- u8* str = new u8[size + FF_INPUT_BUFFER_PADDING_SIZE];
++ u8* str = new u8[size + AV_INPUT_BUFFER_PADDING_SIZE];
+ memcpy(str, stream, size);
+- memset(str + size, 0, FF_INPUT_BUFFER_PADDING_SIZE);
+- size += FF_INPUT_BUFFER_PADDING_SIZE;
++ memset(str + size, 0, AV_INPUT_BUFFER_PADDING_SIZE);
++ size += AV_INPUT_BUFFER_PADDING_SIZE;
+ delete[] stream;
+ stream = str;
+ }
diff --git a/games-emulation/ppsspp/ppsspp-1.5.4-r2.ebuild b/games-emulation/ppsspp/ppsspp-1.5.4-r2.ebuild
index 04fc2542f6a5..4e7f8f7f0271 100644
--- a/games-emulation/ppsspp/ppsspp-1.5.4-r2.ebuild
+++ b/games-emulation/ppsspp/ppsspp-1.5.4-r2.ebuild
@@ -49,6 +49,7 @@ DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}"/${PN}-1.4.2-assets-lookup.patch
"${FILESDIR}"/${PN}-1.4-O2.patch
+ "${FILESDIR}"/${P}-ffmpeg-4.patch
)
src_unpack() {