summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-03-05 01:30:23 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-03-05 01:57:07 -0500
commit068201997e59cd47afce4fda21b12cd0841532ed (patch)
tree3ca070f1754ac83228ea3d908b205a64186c859c /games-emulation/snes9x/files
parentsci-mathematics/alectryon: new package; add 1.4.0 (diff)
downloadgentoo-068201997e59cd47afce4fda21b12cd0841532ed.tar.gz
gentoo-068201997e59cd47afce4fda21b12cd0841532ed.tar.bz2
gentoo-068201997e59cd47afce4fda21b12cd0841532ed.zip
games-emulation/snes9x: add 1.61
Various changes, but for some notable ones: - IUSE=gtk->gui, now uses gtkmm - RESTRICT=test, has no tests but fails if -gui/-gtk (bug #737044) - clean libretro objects to fix USE="netplay libretro" (bug #791475) - respect flags for libretro, also don't use CXXFLAGS for CFLAGS - install libretro core in libretro/ like libretro-snes9x - tentatively remove noexecstack, not seeing QA notices - remove html docs, they are not relevant for users This bundles glslang/spriv-cross but upstream is concerned about API and seems likely this will break if unbundled, leaving alone for now. bug #766782 was caused by CFLAGS = $(CXXFLAGS) without := leading to -fno-rtti being used for CC and seemingly being refusedby distcc. 1.61 corrected this. Closes: https://bugs.gentoo.org/737044 Closes: https://bugs.gentoo.org/766782 Closes: https://bugs.gentoo.org/791475 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-emulation/snes9x/files')
-rw-r--r--games-emulation/snes9x/files/snes9x-1.61-libretro-flags.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/games-emulation/snes9x/files/snes9x-1.61-libretro-flags.patch b/games-emulation/snes9x/files/snes9x-1.61-libretro-flags.patch
new file mode 100644
index 000000000000..297c7d78257d
--- /dev/null
+++ b/games-emulation/snes9x/files/snes9x-1.61-libretro-flags.patch
@@ -0,0 +1,25 @@
+CXXFLAGS is used as a "common" flags variable and passed to CFLAGS,
+but want to use user's CFLAGS for CC rather than CXXFLAGS. Workaround
+with a temporary variable and also drop -O3/lto from defaults.
+--- a/libretro/Makefile
++++ b/libretro/Makefile
+@@ -4,3 +4,5 @@
+
+-LTO ?= -flto
++LTO :=
++ORIG_CXXFLAGS := $(CXXFLAGS)
++CXXFLAGS :=
+ SPACE :=
+@@ -580,4 +582,4 @@
+ else
+- CFLAGS += -O3 -DNDEBUG
+- CXXFLAGS += -O3 -DNDEBUG
++ CFLAGS += -DNDEBUG
++ CXXFLAGS += -DNDEBUG
+ endif
+@@ -612,3 +614,4 @@
+ CXXFLAGS += -DRIGHTSHIFT_IS_SAR -D__LIBRETRO__ -DALLOW_CPU_OVERCLOCK
+-CFLAGS := $(CXXFLAGS)
++CFLAGS := $(CXXFLAGS) $(CFLAGS)
++CXXFLAGS += $(ORIG_CXXFLAGS)
+ CFLAGS += -DHAVE_STDINT_H