summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-03-27 22:17:31 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-03-27 22:25:08 -0400
commitb5c41aa9eb62529656f0ce4bb0bf3565c782a1c0 (patch)
tree54cdfcdd23bd08fe0eafcd4b574918c47a7c5a05 /games-emulation/snes9x
parentapp-emulation/wine-vanilla: add 7.0.2 (diff)
downloadgentoo-b5c41aa9eb62529656f0ce4bb0bf3565c782a1c0.tar.gz
gentoo-b5c41aa9eb62529656f0ce4bb0bf3565c782a1c0.tar.bz2
gentoo-b5c41aa9eb62529656f0ce4bb0bf3565c782a1c0.zip
games-emulation/snes9x: add 1.62.2
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-emulation/snes9x')
-rw-r--r--games-emulation/snes9x/Manifest1
-rw-r--r--games-emulation/snes9x/snes9x-1.62.2.ebuild186
2 files changed, 187 insertions, 0 deletions
diff --git a/games-emulation/snes9x/Manifest b/games-emulation/snes9x/Manifest
index 3964e7efd91e..b08a697c4643 100644
--- a/games-emulation/snes9x/Manifest
+++ b/games-emulation/snes9x/Manifest
@@ -3,5 +3,6 @@ DIST snes9x-1.61-glslang.tar.gz 3188787 BLAKE2B 36ed327fbb2aec3657fe300b98f2e45c
DIST snes9x-1.61-spirv.tar.gz 676662 BLAKE2B ab18406c99e4e04c6c497b5f447dcaccb7d5a60f42bf1cea31afee04ee664e74916b32736c1aea1e7106494154e48e5cbe9b5d6a0652667c4d0e2020814cd9bd SHA512 bfa3cc944450db59a57a685eea12b0ed0b5059d55a092ac5cdf6f4dc03c1e2d2e62fa5a576156c772340e12136b10d7ed790bb35b4aece2ee8405e64f826e31b
DIST snes9x-1.61.tar.gz 3016890 BLAKE2B 3e94dee5172bf48d2461a3a1403fc7e7fc8069df6dddf5b5e1da59ee140297bd0b7cee6948b5eb154c1eec38aebe3ab29a9fae3dfb4abdce41769d2ace43dee1 SHA512 8b644f5b7136e89fd222bcb430fc736c74a3e383d7e6c7f0880235f6fa4c0f77abbf02493f8d654a12e87701111643e33877bc21bb3dfcc9b82a056fa1b1d880
DIST snes9x-1.62.1.tar.gz 3418415 BLAKE2B fa9826f0514d48610086fb1209465bfddac64f88bc0498a97912247922e7fe8e068a92343da7e99307c7f93c48d7103a53f1badf260cef0b9416af7d1a608b8a SHA512 7c0af6df596d8899ee29abf1ac42295f82cff95ffac0db5bb6b4018b03abb3b0768749c1a5e90f44203a1947658023de0e4fcbff20aa863909b15d218e26afc5
+DIST snes9x-1.62.2.tar.gz 3423557 BLAKE2B 8db25f47dd58816eab2bdaf56fc9f83636b8677d9dd37f97fcedd5ef8af12428f1cdd3c4b017569c4930e2616d60c9387e09c0fbe4427860ed1517e1de447458 SHA512 575ce2f46130dcec1eb0168008e64b9f664a694c60b12c4d5d416bde122e2861ca9d10a7597246cbeafe27c4122f24dc82612d585e7f2164fce8b9670100591e
DIST spirv-cross-4e2fdb25671c742a9fbe93a6034eb1542244c7e1.tar.gz 1714902 BLAKE2B ae2b9816755679552c21b7f4446cda5b0626ba56143767445014b011234183afe55b4abbdf2a5849cad3d9e17871362bbac4da6b7969b578f564a8cbb3f3b269 SHA512 ec47b1d966006c6e654e84e7fa16124c774de3ca6fd508d3cfe0568e3df79eee3f5aeedfae1d744b99e162beeee23afe498249b2291091bc14c0357db304bebe
DIST vulkan-headers-a3dd2655a3a68c2a67c55a0f8b77dcb8b166ada2.tar.gz 1832285 BLAKE2B 9278a17ede62f1a839ed230d2eefe3eb7ed46d3e25d4a44504f8d247c7b1c83d38166bec143f3b8e068d5c112585299d90ec16e9c41be6096c61f2eb5e127287 SHA512 b35541413efb5124691e0d13403acc00a85af51e3165828e892e90f059a7d7dc83f9bde43c6a7a1f471ae6eb8ec0155ee873adcc7afb537d5adbaccafcd7d849
diff --git a/games-emulation/snes9x/snes9x-1.62.2.ebuild b/games-emulation/snes9x/snes9x-1.62.2.ebuild
new file mode 100644
index 000000000000..53678735c21a
--- /dev/null
+++ b/games-emulation/snes9x/snes9x-1.62.2.ebuild
@@ -0,0 +1,186 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+inherit autotools cmake flag-o-matic python-any-r1 toolchain-funcs xdg
+
+# TODO: try unbundling, albeit compatibility with (and between) these
+# tend to be volatile and it may not be the best idea "yet"
+HASH_GLSLANG=6d41bb9c557c5a0eec61ffba1f775dc5f717a8f7
+HASH_SPIRV=4e2fdb25671c742a9fbe93a6034eb1542244c7e1
+HASH_VULKAN=a3dd2655a3a68c2a67c55a0f8b77dcb8b166ada2
+
+DESCRIPTION="Super Nintendo Entertainment System (SNES) emulator"
+HOMEPAGE="https://github.com/snes9xgit/snes9x/"
+SRC_URI="
+ https://github.com/snes9xgit/snes9x/archive/${PV}.tar.gz -> ${P}.tar.gz
+ gui? (
+ https://github.com/KhronosGroup/glslang/archive/${HASH_GLSLANG}.tar.gz
+ -> glslang-${HASH_GLSLANG}.tar.gz
+ https://github.com/KhronosGroup/SPIRV-Cross/archive/${HASH_SPIRV}.tar.gz
+ -> spirv-cross-${HASH_SPIRV}.tar.gz
+ https://github.com/KhronosGroup/Vulkan-Headers/archive/${HASH_VULKAN}.tar.gz
+ -> vulkan-headers-${HASH_VULKAN}.tar.gz
+ )"
+
+LICENSE="
+ Snes9x GPL-2 GPL-2+ LGPL-2.1 LGPL-2.1+ ISC MIT ZLIB
+ gui? ( Apache-2.0 CC0-1.0 BSD )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="alsa debug gui libretro netplay oss portaudio pulseaudio wayland xinerama +xv"
+RESTRICT="bindist"
+
+RDEPEND="
+ media-libs/libpng:=
+ sys-libs/zlib:=[minizip]
+ x11-libs/libX11
+ x11-libs/libXext
+ alsa? ( media-libs/alsa-lib )
+ gui? (
+ dev-cpp/cairomm:0
+ dev-cpp/glibmm:2
+ dev-cpp/gtkmm:3.0[wayland?]
+ dev-libs/glib:2
+ dev-libs/libsigc++:2
+ media-libs/libepoxy
+ media-libs/libsdl2[joystick]
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3[wayland?]
+ x11-libs/libXrandr
+ portaudio? ( media-libs/portaudio )
+ pulseaudio? ( media-libs/libpulse )
+ wayland? ( dev-libs/wayland )
+ )
+ libretro? ( !games-emulation/libretro-snes9x )
+ xinerama? ( x11-libs/libXinerama )
+ xv? ( x11-libs/libXv )"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="
+ virtual/pkgconfig
+ gui? ( ${PYTHON_DEPS} )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.62.1-flags.patch
+ "${FILESDIR}"/${PN}-1.62.1-gcc13.patch
+ "${FILESDIR}"/${PN}-1.62.1-optional-wayland.patch
+)
+
+pkg_setup() {
+ # used by bundled glslang
+ use gui && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ if use gui; then
+ rmdir external/{glslang,SPIRV-Cross,vulkan-headers} || die
+ mv ../glslang-${HASH_GLSLANG} external/glslang || die
+ mv ../SPIRV-Cross-${HASH_SPIRV} external/SPIRV-Cross || die
+ mv ../Vulkan-Headers-${HASH_VULKAN} external/vulkan-headers || die
+ fi
+
+ if use gui; then
+ CMAKE_USE_DIR=${S}/gtk
+ cmake_src_prepare
+ else
+ default
+ fi
+
+ pushd unix >/dev/null || die
+ eautoreconf
+ popd >/dev/null || die
+
+ rm -r unzip || die
+}
+
+src_configure() {
+ tc-export CC CXX # for libretro
+
+ local econfargs=(
+ $(use_enable alsa sound-alsa)
+ $(use_enable debug debugger)
+ $(use_enable netplay)
+ $(use_enable xinerama)
+ $(use_enable xv xvideo)
+ --enable-gamepad
+ --enable-gzip
+ --enable-screenshot
+ --enable-zip
+ --disable-libyuv # unpackaged
+ --with-system-zip
+ )
+
+ pushd unix >/dev/null || die
+ econf "${econfargs[@]}"
+ popd >/dev/null || die
+
+ if use gui; then
+ # bundled SPIRV-Cross fails with -Werror=odr
+ filter-lto
+
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=no
+ -DDEBUGGER=$(usex debug)
+ -DUSE_ALSA=$(usex alsa)
+ -DUSE_OSS=$(usex oss)
+ -DUSE_PORTAUDIO=$(usex portaudio)
+ -DUSE_PULSEAUDIO=$(usex pulseaudio)
+ -DUSE_SYSTEMZIP=yes
+ -DUSE_WAYLAND=$(usex wayland)
+ -DUSE_XV=$(usex xv)
+
+ # this controls both vulkan output and shader support, could be
+ # behind a USE but it currently fails to build if disabled and
+ # adds no dependencies given they are bundled (for now)
+ -DUSE_SLANG=yes
+
+ # gets used for LOCALE/DATADIR too early (installs to /usr//locale)
+ -DCMAKE_INSTALL_DATAROOTDIR=share
+ )
+
+ cmake_src_configure
+ fi
+}
+
+src_compile() {
+ if use libretro; then
+ emake -C libretro LTO=
+ # rebuild objects given libretro uses different defines (bug #791475)
+ rm *.o || die
+ fi
+
+ emake -C unix
+
+ use gui && cmake_src_compile
+}
+
+src_test() {
+ # currently no tests, but don't run the cmake phase while unconfigured
+ use gui && cmake_src_test
+}
+
+src_install() {
+ if use libretro; then
+ exeinto /usr/$(get_libdir)/libretro
+ doexe libretro/snes9x_libretro.so
+ fi
+
+ dobin unix/snes9x
+
+ local DOCS=(
+ README.md
+ docs/{changes,control-inputs,controls,snapshots}.txt
+ unix/snes9x.conf.default
+ )
+ einstalldocs
+
+ if use gui; then
+ DOCS=( AUTHORS )
+ cmake_src_install
+ fi
+}