summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNado <nado@troglodyte.be>2018-01-12 23:36:25 +0100
committerDavid Seifert <soap@gentoo.org>2018-01-13 23:17:17 +0100
commit9da917d8e4fdf15ddae409534ea7c4bc29e6115c (patch)
tree87f7730e5bedc099eec5193a697dccef1cc22b20 /games-emulation/vbam/vbam-9999.ebuild
parentdev-libs/sway: drop old 0.14.0 & 0.15.0 (diff)
downloadgentoo-9da917d8e4fdf15ddae409534ea7c4bc29e6115c.tar.gz
gentoo-9da917d8e4fdf15ddae409534ea7c4bc29e6115c.tar.bz2
gentoo-9da917d8e4fdf15ddae409534ea7c4bc29e6115c.zip
games-emulation/vbam: 9999 update to new requirements from upstream
* switch from fdo-mime to xdg-utils * add missing REQUIRED_USE constraints * remove gtk port as it is no longer supported by upstream * remove cairo support for the same reason Closes: https://bugs.gentoo.org/638300 Package-Manager: Portage-2.3.19, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/6847
Diffstat (limited to 'games-emulation/vbam/vbam-9999.ebuild')
-rw-r--r--games-emulation/vbam/vbam-9999.ebuild31
1 files changed, 12 insertions, 19 deletions
diff --git a/games-emulation/vbam/vbam-9999.ebuild b/games-emulation/vbam/vbam-9999.ebuild
index 0af06c4e2c8c..357c94893101 100644
--- a/games-emulation/vbam/vbam-9999.ebuild
+++ b/games-emulation/vbam/vbam-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
WX_GTK_VER="3.0"
-inherit cmake-utils wxwidgets gnome2-utils fdo-mime eutils
+inherit cmake-utils wxwidgets gnome2-utils eutils xdg-utils
if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/visualboyadvance-m/visualboyadvance-m.git"
@@ -18,8 +18,8 @@ HOMEPAGE="https://github.com/visualboyadvance-m/visualboyadvance-m"
LICENSE="GPL-2"
SLOT="0"
-IUSE="cairo ffmpeg gtk link lirc nls openal +sdl wxwidgets"
-REQUIRED_USE="|| ( sdl gtk wxwidgets )"
+IUSE="ffmpeg link lirc nls openal +sdl wxwidgets"
+REQUIRED_USE="openal? ( wxwidgets ) || ( sdl wxwidgets )"
RDEPEND=">=media-libs/libpng-1.4:0=
media-libs/libsdl2[joystick]
@@ -28,13 +28,9 @@ RDEPEND=">=media-libs/libpng-1.4:0=
virtual/glu
virtual/opengl
ffmpeg? ( virtual/ffmpeg[-libav] )
- gtk? ( >=dev-cpp/glibmm-2.4.0:2
- >=dev-cpp/gtkmm-2.4.0:2.4
- >=dev-cpp/gtkglextmm-1.2.0 )
lirc? ( app-misc/lirc )
nls? ( virtual/libintl )
wxwidgets? (
- cairo? ( x11-libs/cairo )
openal? ( media-libs/openal )
x11-libs/wxGTK:${WX_GTK_VER}[X,opengl]
)"
@@ -48,15 +44,13 @@ src_prepare() {
default
# fix desktop file QA warnings
- edos2unix src/gtk/gvbam.desktop src/wx/wxvbam.desktop
+ edos2unix src/wx/wxvbam.desktop
}
src_configure() {
use wxwidgets && setup-wxwidgets
local mycmakeargs=(
- -DENABLE_CAIRO=$(usex cairo)
-DENABLE_FFMPEG=$(usex ffmpeg)
- -DENABLE_GTK=$(usex gtk)
-DENABLE_LINK=$(usex link)
-DENABLE_LIRC=$(usex lirc)
-DENABLE_NLS=$(usex nls)
@@ -79,28 +73,27 @@ src_install() {
if use sdl ; then
dodoc doc/ReadMe.SDL.txt
- doman src/debian/vbam.1
+ doman src/debian/vbam.6
fi
- use wxwidgets && doman src/debian/wxvbam.1
- use gtk && doman src/debian/gvbam.1
+ use wxwidgets && doman src/debian/visualboyadvance-m.6
}
pkg_preinst() {
- if use gtk || use wxwidgets ; then
+ if use wxwidgets ; then
gnome2_icon_savelist
fi
}
pkg_postinst() {
- if use gtk || use wxwidgets ; then
+ if use wxwidgets ; then
gnome2_icon_cache_update
+ xdg_desktop_database_update
fi
- use gtk && fdo-mime_desktop_database_update
}
pkg_postrm() {
- if use gtk || use wxwidgets ; then
+ if use wxwidgets ; then
gnome2_icon_cache_update
+ xdg_desktop_database_update
fi
- use gtk && fdo-mime_desktop_database_update
}