summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-07-15 21:21:32 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-07-15 21:27:55 +0200
commit8b6cc02dcadf1e0d9dc8df3e4c5ed045d44fbb71 (patch)
tree9a6ec97480e32d2aa8c73ddbb99ff2f1017dc08c /games-emulation/yabause/yabause-0.9.15.ebuild
parentdev-ruby/actioncable: cleanup (diff)
downloadgentoo-8b6cc02dcadf1e0d9dc8df3e4c5ed045d44fbb71.tar.gz
gentoo-8b6cc02dcadf1e0d9dc8df3e4c5ed045d44fbb71.tar.bz2
gentoo-8b6cc02dcadf1e0d9dc8df3e4c5ed045d44fbb71.zip
games-emulation/yabause: 0.9.15 version bump, EAPI-6, fix Qt 5.11
Drop games.eclass. Make USE=qt5 default per upstream recommendation. Disabling SH2_DYNAREC due to being broken, see also: https://github.com/Yabause/yabause/issues/270 Thanks-to: Samuel BAUER <BM-2cTVBXjxdVtEQCycBQjMxszLsgTNVujvM5@bitmessage.ch> Bug: https://bugs.gentoo.org/582326 Closes: https://bugs.gentoo.org/654674 Closes: https://bugs.gentoo.org/660458 Package-Manager: Portage-2.3.42, Repoman-2.3.9
Diffstat (limited to 'games-emulation/yabause/yabause-0.9.15.ebuild')
-rw-r--r--games-emulation/yabause/yabause-0.9.15.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/games-emulation/yabause/yabause-0.9.15.ebuild b/games-emulation/yabause/yabause-0.9.15.ebuild
new file mode 100644
index 000000000000..b0f88a4d472e
--- /dev/null
+++ b/games-emulation/yabause/yabause-0.9.15.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="A Sega Saturn emulator"
+HOMEPAGE="https://yabause.org/"
+SRC_URI="https://download.tuxfamily.org/${PN}/releases/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="openal opengl +qt5 sdl"
+
+# Qt5 is the recommended UI and 0.9.15 the last release w/ GTK+
+RDEPEND="
+ sys-libs/zlib:=
+ x11-libs/libXrandr
+ x11-libs/libX11
+ openal? ( media-libs/openal )
+ opengl? (
+ media-libs/freeglut
+ virtual/glu
+ virtual/opengl
+ )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtwidgets:5
+ opengl? ( dev-qt/qtopengl:5 )
+ )
+ !qt5? (
+ dev-libs/glib:2
+ x11-libs/gtk+:2
+ x11-libs/gtkglext
+ )
+ sdl? ( media-libs/libsdl2[opengl?,video] )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-RWX.patch
+ "${FILESDIR}"/${P}-qt-5.11.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DYAB_NETWORK=ON
+ -DYAB_USE_CXX=ON
+ -DYAB_USE_SCSP2=OFF # breaks build
+ -DYAB_USE_SCSPMIDI=ON
+ -DYAB_USE_SSF=ON
+ -DSH2_DYNAREC=OFF # bug 582326
+ -DYAB_OPTIMIZATION=""
+ -DYAB_WANT_MPEG=OFF
+ -DYAB_WANT_SDL=$(usex sdl)
+ -DYAB_WANT_OPENAL=$(usex openal)
+ -DYAB_WANT_OPENGL=$(usex opengl)
+ -DYAB_PORTS=$(usex qt5 "qt" "gtk")
+ )
+ cmake-utils_src_configure
+}