summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-09-10 14:03:46 -0400
committerMichael Sterrett <mr_bones_@gentoo.org>2015-09-10 14:03:46 -0400
commitf2a0fd366bf7ce4e16b92169a64c94cc465247ae (patch)
tree8e16f8252663554411b7d7cbbc022fe48d701138 /games-emulation/zsnes/zsnes-1.51-r4.ebuild
parentkde5.eclass: Block old kde4-l10n for kde-{frameworks,plasma} (diff)
downloadgentoo-f2a0fd366bf7ce4e16b92169a64c94cc465247ae.tar.gz
gentoo-f2a0fd366bf7ce4e16b92169a64c94cc465247ae.tar.bz2
gentoo-f2a0fd366bf7ce4e16b92169a64c94cc465247ae.zip
don't depend on specific autotools behavior to build (bug #559766)
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'games-emulation/zsnes/zsnes-1.51-r4.ebuild')
-rw-r--r--games-emulation/zsnes/zsnes-1.51-r4.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/games-emulation/zsnes/zsnes-1.51-r4.ebuild b/games-emulation/zsnes/zsnes-1.51-r4.ebuild
index 0fedbe9ca3ab..1daadac483a7 100644
--- a/games-emulation/zsnes/zsnes-1.51-r4.ebuild
+++ b/games-emulation/zsnes/zsnes-1.51-r4.ebuild
@@ -49,7 +49,8 @@ src_prepare() {
"${FILESDIR}"/${P}-buffer.patch \
"${FILESDIR}"/${P}-gcc47.patch \
"${FILESDIR}"/${P}-stack-align.patch \
- "${FILESDIR}"/${P}-cross-compile.patch
+ "${FILESDIR}"/${P}-cross-compile.patch \
+ "${FILESDIR}"/${P}-arch.patch
# The sdl detection logic uses AC_PROG_PATH instead of
# AC_PROG_TOOL, so force the var to get set the way we
@@ -76,6 +77,7 @@ src_prepare() {
src_configure() {
tc-export CC
export BUILD_CXX=$(tc-getBUILD_CXX)
+ export NFLAGS=-O1
use amd64 && multilib_toolchain_setup x86
use custom-cflags || strip-flags
@@ -87,9 +89,7 @@ src_configure() {
$(use_enable png libpng) \
$(use_enable opengl) \
--disable-debug \
- --disable-cpucheck \
- --enable-release \
- force_arch=no
+ --disable-cpucheck
}
src_compile() {