summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-02-09 13:51:42 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-02-09 13:51:42 -0500
commit0a8afb2aa22880dcad3168e6f0c0bde4b95fe757 (patch)
treeb50db2a635c3e0d98abc03bb864eec5e1a151122 /games-emulation
parentgames-emulation/nestopia: add 1.51.1 (diff)
downloadgentoo-0a8afb2aa22880dcad3168e6f0c0bde4b95fe757.tar.gz
gentoo-0a8afb2aa22880dcad3168e6f0c0bde4b95fe757.tar.bz2
gentoo-0a8afb2aa22880dcad3168e6f0c0bde4b95fe757.zip
games-emulation/nestopia: sync live
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/nestopia/nestopia-9999.ebuild21
1 files changed, 12 insertions, 9 deletions
diff --git a/games-emulation/nestopia/nestopia-9999.ebuild b/games-emulation/nestopia/nestopia-9999.ebuild
index 98f2f70517d9..c6bdbe0d6fb8 100644
--- a/games-emulation/nestopia/nestopia-9999.ebuild
+++ b/games-emulation/nestopia/nestopia-9999.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools xdg
-DESCRIPTION="A portable Nintendo Entertainment System emulator written in C++"
+DESCRIPTION="Portable Nintendo Entertainment System emulator written in C++"
HOMEPAGE="http://0ldsk00l.ca/nestopia/"
-if [[ ${PV} == *9999 ]]; then
+if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/0ldsk00l/nestopia.git"
else
@@ -22,15 +22,18 @@ IUSE="doc"
RDEPEND="
app-arch/libarchive:=
- media-libs/libepoxy
- media-libs/libsdl2[sound,joystick,video]
- sys-libs/zlib
- x11-libs/gtk+:3"
+ media-libs/libglvnd
+ media-libs/libsdl2[joystick,sound]
+ sys-libs/zlib:=
+ x11-libs/fltk:1[opengl]"
DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
+BDEPEND="
+ sys-devel/autoconf-archive
+ virtual/pkgconfig"
src_prepare() {
default
+
eautoreconf
}