summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Konotopov <ykonotopov@gnome.org>2021-01-03 20:42:40 +0400
committerJoonas Niilola <juippis@gentoo.org>2021-01-15 10:44:37 +0200
commit184059373078ce9051f344fecacd2e7697c4c399 (patch)
tree7302dc33f19a001a4245ea613e87e175d13c2cac /games-emulation
parentdev-util/diffoscope: add python[ncurses] depend (diff)
downloadgentoo-184059373078ce9051f344fecacd2e7697c4c399.tar.gz
gentoo-184059373078ce9051f344fecacd2e7697c4c399.tar.bz2
gentoo-184059373078ce9051f344fecacd2e7697c4c399.zip
games-emulation/pcsx2: update to match upstream changes
Closes: https://bugs.gentoo.org/762157 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Yuri Konotopov <ykonotopov@gnome.org> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/pcsx2/pcsx2-9999.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/games-emulation/pcsx2/pcsx2-9999.ebuild b/games-emulation/pcsx2/pcsx2-9999.ebuild
index 764020699ad5..c6a8c52c1625 100644
--- a/games-emulation/pcsx2/pcsx2-9999.ebuild
+++ b/games-emulation/pcsx2/pcsx2-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -18,6 +18,7 @@ IUSE=""
RDEPEND="
app-arch/bzip2[abi_x86_32(-)]
app-arch/xz-utils[abi_x86_32(-)]
+ dev-cpp/yaml-cpp:=[abi_x86_32(-)]
dev-libs/libaio[abi_x86_32(-)]
dev-libs/libfmt:=[abi_x86_32(-)]
dev-libs/libxml2:2[abi_x86_32(-)]
@@ -34,7 +35,7 @@ RDEPEND="
x11-libs/libICE[abi_x86_32(-)]
x11-libs/libX11[abi_x86_32(-)]
x11-libs/libXext[abi_x86_32(-)]
- >=x11-libs/wxGTK-3.0.4-r301:3.0-gtk3[abi_x86_32(-),X]
+ x11-libs/wxGTK:3.0-gtk3[abi_x86_32(-),X]
"
DEPEND="${RDEPEND}
dev-cpp/pngpp
@@ -82,11 +83,9 @@ src_configure() {
-DXDG_STD=TRUE
-DCMAKE_LIBRARY_PATH="/usr/$(get_libdir)/${PN}"
- -DDOC_DIR=/usr/share/doc/"${PF}"
- -DGTK3_API=TRUE
- -DPLUGIN_DIR="/usr/$(get_libdir)/${PN}"
# wxGTK must be built against same sdl version
-DSDL2_API=TRUE
+ -DUSE_SYSTEM_YAML=TRUE
-DUSE_VTUNE=FALSE
)
@@ -99,6 +98,6 @@ src_install() {
# https://github.com/PCSX2/pcsx2/issues/417
# https://github.com/PCSX2/pcsx2/issues/3077
QA_EXECSTACK="usr/bin/PCSX2"
- QA_TEXTRELS="usr/$(get_libdir)/pcsx2/* usr/bin/PCSX2"
+ QA_TEXTRELS="usr/$(get_libdir)/PCSX2/* usr/bin/PCSX2"
cmake_src_install
}