summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-03-08 14:59:19 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-03-08 14:59:29 +0100
commit1ce9e1f56a7bacf2dcb625b0b0d9710f736d0b9b (patch)
tree876838b29c6ec98afbfb9279e5e7e9acc297158c /games-emulation
parentnet-libs/libnice: crank up glib lower bound (diff)
downloadgentoo-1ce9e1f56a7bacf2dcb625b0b0d9710f736d0b9b.tar.gz
gentoo-1ce9e1f56a7bacf2dcb625b0b0d9710f736d0b9b.tar.bz2
gentoo-1ce9e1f56a7bacf2dcb625b0b0d9710f736d0b9b.zip
games-emulation/melonds: bump to 0.9.4
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/melonds/Manifest1
-rw-r--r--games-emulation/melonds/melonds-0.9.4.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/games-emulation/melonds/Manifest b/games-emulation/melonds/Manifest
index 3a233230003e..dee66208acc3 100644
--- a/games-emulation/melonds/Manifest
+++ b/games-emulation/melonds/Manifest
@@ -1 +1,2 @@
DIST melonDS-0.9.3.tar.gz 2241325 BLAKE2B 0ea7fbcce039a60a0553ae45d11f0b1550bfec2300faf1c99c3ee531bd5949c7293bec187fbf53e400bbb6280df29db141b2d1bcb294a8abf2eabb71993db686 SHA512 37f26f3a9784873ce1664645cea70049725367f5fe62f7c58842ebd5da2c73ffe423695dddb0ffd444bdf59df2a3fcd778cdf95b2bb083014b961fed282953f5
+DIST melonDS-0.9.4.tar.gz 2330626 BLAKE2B 8da363e0345ede978973d29b58c50cd79df5de999abb098a61195d084aed9584273d2a193f8a194642632c4458e3b9bbe11818ae489e1994bb5befa1e1ecf1b2 SHA512 86bb046e180443fe07b27208d08515b0303d3cdb29acad7950d30a55f7baf32c41a4c9ce2f7a681d590e83addc56eb5857e3c7aca5bbfea9b5abe4ce63bdc278
diff --git a/games-emulation/melonds/melonds-0.9.4.ebuild b/games-emulation/melonds/melonds-0.9.4.ebuild
new file mode 100644
index 000000000000..54b2216e33ab
--- /dev/null
+++ b/games-emulation/melonds/melonds-0.9.4.ebuild
@@ -0,0 +1,88 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# NOTICE:
+# melonds bundles teakra, its upstream haven't had a release since 2020
+
+EAPI=8
+
+MY_PN="melonDS"
+MY_P="${MY_PN}-${PV}"
+
+inherit cmake flag-o-matic readme.gentoo-r1 toolchain-funcs xdg
+
+DESCRIPTION="Nintendo DS emulator, sorta"
+HOMEPAGE="
+ http://melonds.kuribo64.net
+ https://github.com/Arisotura/melonDS
+"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Arisotura/${MY_PN}.git"
+else
+ SRC_URI="https://github.com/Arisotura/${MY_PN}/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+IUSE="+jit +opengl"
+LICENSE="BSD-2 GPL-2 GPL-3 Unlicense"
+SLOT="0"
+
+DEPEND="
+ app-arch/libarchive
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ media-libs/libsdl2[sound,video]
+ net-libs/libpcap
+ net-libs/libslirp
+ opengl? ( media-libs/libepoxy )
+"
+RDEPEND="${DEPEND}"
+
+# used for JIT recompiler
+QA_EXECSTACK="usr/bin/melonDS"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="You need the following files in order to run melonDS:
+- bios7.bin
+- bios9.bin
+- firmware.bin
+- romlist.bin
+Place them in ~/.config/melonDS
+Those files can be found somewhere on the Internet ;-)"
+
+src_prepare() {
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_JIT=$(usex jit)
+ -DENABLE_OGLRENDERER=$(usex opengl)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ tc-export AR
+ cmake_src_compile
+}
+
+src_install() {
+ # install teakra
+ dolib.so "${BUILD_DIR}/src/teakra/src/libteakra.so"
+
+ cmake_src_install
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ readme.gentoo_print_elog
+}