summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-02-16 17:47:21 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-02-16 18:09:49 -0500
commit1f781826a1c70818ec1168862af737ef81c67bfd (patch)
tree452150be6fa52b5074d133996170d589c653b88a /games-emulation
parentdev-python/cfn-lint: Bump to 0.58.1 (diff)
downloadgentoo-1f781826a1c70818ec1168862af737ef81c67bfd.tar.gz
gentoo-1f781826a1c70818ec1168862af737ef81c67bfd.tar.bz2
gentoo-1f781826a1c70818ec1168862af737ef81c67bfd.zip
games-emulation/pcsx2: drop passing unnecessary toolchain file
Undocumented not-for-ebuilds MYCMAKEARGS was used as a way to replace the toolchain file, however Gentoo's is perfectly fine here thanks to `multilib_toolchain_setup x86` setting this up. Still revbump to ~arch as a precaution, but should be fine. Could use some other fixups but ideal would be for a new release (or maybe start looking into snapshots after upstream stops doing major changes) to get rid of all this 32bit stuff. Bug: https://bugs.gentoo.org/833100 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/pcsx2/pcsx2-1.6.0-r3.ebuild103
1 files changed, 103 insertions, 0 deletions
diff --git a/games-emulation/pcsx2/pcsx2-1.6.0-r3.ebuild b/games-emulation/pcsx2/pcsx2-1.6.0-r3.ebuild
new file mode 100644
index 000000000000..cc399bd2cc8a
--- /dev/null
+++ b/games-emulation/pcsx2/pcsx2-1.6.0-r3.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+WX_GTK_VER="3.0-gtk3"
+inherit cmake fcaps flag-o-matic multilib toolchain-funcs wxwidgets
+
+MY_PV="${PV/_/-}"
+
+DESCRIPTION="A PlayStation 2 emulator"
+HOMEPAGE="https://pcsx2.net/"
+SRC_URI="https://github.com/PCSX2/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+RDEPEND="
+ app-arch/bzip2[abi_x86_32(-)]
+ app-arch/xz-utils[abi_x86_32(-)]
+ dev-libs/libaio[abi_x86_32(-)]
+ dev-libs/libxml2:2[abi_x86_32(-)]
+ media-libs/alsa-lib[abi_x86_32(-)]
+ media-libs/libpng:=[abi_x86_32(-)]
+ media-libs/libsdl2[abi_x86_32(-),haptic,joystick,sound]
+ media-libs/libsoundtouch[abi_x86_32(-)]
+ media-libs/portaudio[abi_x86_32(-)]
+ net-libs/libpcap[abi_x86_32(-)]
+ sys-libs/zlib[abi_x86_32(-)]
+ virtual/libudev[abi_x86_32(-)]
+ virtual/opengl[abi_x86_32(-)]
+ x11-libs/gtk+:3[abi_x86_32(-)]
+ x11-libs/libICE[abi_x86_32(-)]
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+ x11-libs/wxGTK:${WX_GTK_VER}[abi_x86_32(-),X]
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+FILECAPS=(
+ -m 755 "CAP_NET_RAW+eip CAP_NET_ADMIN+eip" usr/bin/PCSX2
+)
+
+PATCHES=(
+ "${FILESDIR}/${P}-disable-setcap.patch"
+)
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary && $(tc-getCC) == *gcc* ]]; then
+ # -mxsave flag is needed when GCC >= 8.2 is used
+ # https://bugs.gentoo.org/685156
+ if [[ $(gcc-major-version) -gt 8 || $(gcc-major-version) == 8 && $(gcc-minor-version) -ge 2 ]]; then
+ append-flags -mxsave
+ fi
+ fi
+}
+
+src_configure() {
+ multilib_toolchain_setup x86
+ # Build with ld.gold fails
+ # https://github.com/PCSX2/pcsx2/issues/1671
+ tc-ld-disable-gold
+
+ # pcsx2 build scripts will force CMAKE_BUILD_TYPE=Devel
+ # if it something other than "Devel|Debug|Release"
+ local CMAKE_BUILD_TYPE="Release"
+
+ local mycmakeargs=(
+ -DARCH_FLAG=
+ -DDISABLE_BUILD_DATE=TRUE
+ -DDISABLE_PCSX2_WRAPPER=TRUE
+ -DDISABLE_SETCAP=TRUE
+ -DEXTRA_PLUGINS=FALSE
+ -DOPTIMIZATION_FLAG=
+ -DPACKAGE_MODE=TRUE
+ -DXDG_STD=TRUE
+
+ -DCMAKE_LIBRARY_PATH="/usr/$(get_libdir)/${PN}"
+ -DDOC_DIR=/usr/share/doc/"${PF}"
+ -DEGL_API=FALSE
+ -DGTK3_API=TRUE
+ -DOPENCL_API=FALSE
+ -DPLUGIN_DIR="/usr/$(get_libdir)/${PN}"
+ # wxGTK must be built against same sdl version
+ -DSDL2_API=TRUE
+ -DUSE_VTUNE=FALSE
+ )
+
+ setup-wxwidgets
+ cmake_src_configure
+}
+
+src_install() {
+ # Upstream issues:
+ # https://github.com/PCSX2/pcsx2/issues/417
+ # https://github.com/PCSX2/pcsx2/issues/3077
+ QA_EXECSTACK="usr/bin/PCSX2"
+ QA_TEXTRELS="usr/$(get_libdir)/pcsx2/* usr/bin/PCSX2"
+ cmake_src_install
+}