summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-01-21 14:04:58 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-01-21 19:32:36 -0500
commit26f9027af69ec1b6d6107fc7816c889963c61d4b (patch)
treef1c352503d3c055f81ffaab6bd04aec2003fb097 /games-emulation
parentgames-emulation/fceux: drop 2.5.0, 2.6.0 (diff)
downloadgentoo-26f9027af69ec1b6d6107fc7816c889963c61d4b.tar.gz
gentoo-26f9027af69ec1b6d6107fc7816c889963c61d4b.tar.bz2
gentoo-26f9027af69ec1b6d6107fc7816c889963c61d4b.zip
games-emulation/desmume: drop 0.9.11_p20210409-r1
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/desmume/Manifest1
-rw-r--r--games-emulation/desmume/desmume-0.9.11_p20210409-r1.ebuild53
-rw-r--r--games-emulation/desmume/files/desmume-0.9.11_p20210409-clang.patch16
3 files changed, 0 insertions, 70 deletions
diff --git a/games-emulation/desmume/Manifest b/games-emulation/desmume/Manifest
index 924917bf4ae5..1552b4c0f524 100644
--- a/games-emulation/desmume/Manifest
+++ b/games-emulation/desmume/Manifest
@@ -1,2 +1 @@
-DIST desmume-0.9.11_p20210409.tar.gz 13157043 BLAKE2B f8e582005555357cb632478ba8d2730e51a5cb8dbbee05d4af138df19a015ced6cff721fb53f87224774aed8287f91a01da5600f5548189fd0e264e5b3037fd8 SHA512 1897b3b35c7e997876ff53a36849a39b85bd49c737dab61f68c376e3cb294486f9edded98924275e8ee91e5b008e9d3814987edaab7306217c17dbc094f69348
DIST desmume-0.9.11_p20211119.tar.gz 13266678 BLAKE2B 0af12f9fd7f3448d4f18a61ec65f1a64926f402827bd9eb8af4a06766390dc626940c327e2bb0ff17d4d62eefe1171c4a836e98dbbbc34bf5d4e9e6d886189a0 SHA512 53553771b51741c2c553e47befec1eb90bdaa3c9ff239bdb301054dbaf5c483c768dac440fece797c9756f3c1490ad61da59b3b5728328b7f23aaa5e1de40625
diff --git a/games-emulation/desmume/desmume-0.9.11_p20210409-r1.ebuild b/games-emulation/desmume/desmume-0.9.11_p20210409-r1.ebuild
deleted file mode 100644
index 9cc9dd366242..000000000000
--- a/games-emulation/desmume/desmume-0.9.11_p20210409-r1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit meson xdg
-
-MY_COMMIT="e8f619c44a23ebba06be1fb4442483d481477b81"
-
-DESCRIPTION="Nintendo DS emulator"
-HOMEPAGE="https://desmume.org/"
-SRC_URI="https://github.com/TASVideos/desmume/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}-${MY_COMMIT}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="gdb +gui openal wifi"
-
-RDEPEND="
- dev-libs/glib:2
- media-libs/alsa-lib
- media-libs/libsdl2[X,opengl,sound,video]
- media-libs/libsoundtouch:=
- net-libs/libpcap
- sys-libs/zlib:=
- virtual/opengl
- x11-libs/agg
- x11-libs/libX11
- gui? ( x11-libs/gtk+:3 )
- openal? ( media-libs/openal )"
-DEPEND="
- ${RDEPEND}
- x11-base/xorg-proto"
-
-PATCHES=(
- "${FILESDIR}"/${P}-fix-gtk-cliopts.patch
- "${FILESDIR}"/${P}-openal-automagic.patch
- "${FILESDIR}"/${P}-clang.patch
-)
-
-DOCS=( ${PN}/{AUTHORS,ChangeLog,README,README.LIN,doc/.} )
-
-src_configure() {
- local EMESON_SOURCE="${S}/${PN}/src/frontend/posix"
- local emesonargs=(
- $(meson_use gdb gdb-stub)
- $(meson_use gui frontend-gtk)
- $(meson_use openal)
- $(meson_use wifi)
- )
- meson_src_configure
-}
diff --git a/games-emulation/desmume/files/desmume-0.9.11_p20210409-clang.patch b/games-emulation/desmume/files/desmume-0.9.11_p20210409-clang.patch
deleted file mode 100644
index 164cb5af4836..000000000000
--- a/games-emulation/desmume/files/desmume-0.9.11_p20210409-clang.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Fix build with clang https://bugs.gentoo.org/739144
-
-Fixed upstream in: https://github.com/TASVideos/desmume/commit/92cb90f
---- a/desmume/src/texcache.cpp
-+++ b/desmume/src/texcache.cpp
-@@ -1165,8 +1165,8 @@ void NDSTextureUnpack4x4(const size_t sr
-
- for (size_t y = 0, d = 0; y < yTmpSize; y++)
- {
-- u32 tmpPos[4]={(y<<2)*sizeX,((y<<2)+1)*sizeX,
-- ((y<<2)+2)*sizeX,((y<<2)+3)*sizeX};
-+ u32 tmpPos[4]={u32(y<<2)*sizeX,u32((y<<2)+1)*sizeX,
-+ u32((y<<2)+2)*sizeX,u32((y<<2)+3)*sizeX};
- for (size_t x = 0; x < xTmpSize; x++, d++)
- {
- if (d >= limit)