summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-01-19 11:44:48 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-01-19 11:45:01 -0500
commit2f67555306927d6bf6e93328a2be6c45d654842b (patch)
tree9bd1ac535cabad994284165fb67232461797aa41 /games-emulation
parentnet-libs/canlock: KEYWORDS~3.3.0, fix UnusedInherit (diff)
downloadgentoo-2f67555306927d6bf6e93328a2be6c45d654842b.tar.gz
gentoo-2f67555306927d6bf6e93328a2be6c45d654842b.tar.bz2
gentoo-2f67555306927d6bf6e93328a2be6c45d654842b.zip
games-emulation/mednafen: add 1.29.0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/mednafen/Manifest1
-rw-r--r--games-emulation/mednafen/mednafen-1.29.0.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/games-emulation/mednafen/Manifest b/games-emulation/mednafen/Manifest
index 5ef17b7c8d8c..03d23eaad428 100644
--- a/games-emulation/mednafen/Manifest
+++ b/games-emulation/mednafen/Manifest
@@ -1 +1,2 @@
DIST mednafen-1.27.1.tar.xz 3363540 BLAKE2B f74c251300af2348db00d68ef2cd998bdf4d6fb06873e03e0027d836b5b1217901b1e2cf922877b1db4c278ba4cc2674e4875a17fff52a3b8be5a447670a6385 SHA512 f55d86baa8c77fc98aae63a38235eb64f64131f180c40ed1ac7cd2ad845230348fbba05643eb5e6af203e56c39c8011b632d2bcecbd2c9f2c19b2447f6b99e83
+DIST mednafen-1.29.0.tar.xz 3512784 BLAKE2B bea5ecfe00f97d1cf81eccfe4264d8fea666c9c8543449ca8c1e4e064f89a100f6bbe77b23d42d5d9c4a7e005792006d599852a201f1d95a756742bc58ecda81 SHA512 375f0fb4f12907faf56b4e9ecdc44c1655b0660a3773240fe3118f2b261e171479b8eb254299f899fc442b54041c941eab2a5f343aec559d9731c3e92cde0569
diff --git a/games-emulation/mednafen/mednafen-1.29.0.ebuild b/games-emulation/mednafen/mednafen-1.29.0.ebuild
new file mode 100644
index 000000000000..a57c4dde457d
--- /dev/null
+++ b/games-emulation/mednafen/mednafen-1.29.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic pax-utils toolchain-funcs
+
+DESCRIPTION="Argument-driven multi-system emulator utilizing OpenGL and SDL"
+HOMEPAGE="https://mednafen.github.io/"
+SRC_URI="https://mednafen.github.io/releases/files/${P}.tar.xz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa cpu_flags_ppc_altivec flac jack"
+
+RDEPEND="
+ app-arch/zstd:=
+ dev-libs/lzo:2
+ dev-libs/trio
+ media-libs/libsdl2[joystick,opengl,video]
+ media-libs/tremor
+ media-sound/musepack-tools
+ sys-libs/zlib:=[minizip]
+ virtual/libintl
+ alsa? ( media-libs/alsa-lib )
+ flac? ( media-libs/flac )
+ jack? ( virtual/jack )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # don't let the build system mess with CFLAGS more than necessary,
+ # most are questionable (see README.PORTING/configure.ac comments)
+ # -fwrapv: kept for bug #539992
+ sed -e '/CC_OPT.*CODEGEN_FLAGS/{/-fwrapv/!d}' \
+ -e '/CC_OPT.*NOPICPIE_FLAGS/d' \
+ -e '/CC_OPT.*NO_STACK_PROTECTOR_FLAGS/d' \
+ -e '/CC_OPT.*OPTIMIZER_FLAGS/c\:' \
+ -e '/CC_OPT.*-mtune.*SS_EXTRA_FLAGS/d' \
+ -e '/LINK_FLAG.*NOPICPIE_LDFLAGS/d' \
+ -i configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ # disable unnecessary warnings not to confuse users (see src/types.h)
+ append-cppflags -DMDFN_DISABLE_{NO_OPT,PICPIE}_ERRWARN
+
+ local myeconfargs=(
+ $(use_enable alsa)
+ $(use_enable cpu_flags_ppc_altivec altivec)
+ $(use_enable jack)
+ $(use_with flac libflac)
+ --with-external-{libzstd,lzo,mpcdec,tremor,trio}
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ local DOCS=(
+ ChangeLog
+ Documentation/{cheats.txt,fname_format.txt,modules.def,settings.def}
+ )
+ local HTML_DOCS=( Documentation/*.{css,html,png} )
+
+ default
+
+ pax-mark m "${ED}"/usr/bin/mednafen
+}