summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Konotopov <ykonotopov@gnome.org>2020-03-09 19:19:57 +0400
committerJoonas Niilola <juippis@gentoo.org>2020-03-14 14:06:53 +0200
commit374226702cb0c2959056cc493cdb90e3da009714 (patch)
treeff967b665b845d0a494efefa96f59daba22cea73 /games-emulation
parentdev-ruby/rspec-rails: add 3.9.1 (diff)
downloadgentoo-374226702cb0c2959056cc493cdb90e3da009714.tar.gz
gentoo-374226702cb0c2959056cc493cdb90e3da009714.tar.bz2
gentoo-374226702cb0c2959056cc493cdb90e3da009714.zip
games-emulation/pcsx2: version bump to 1.6.0-rc
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Yuri Konotopov <ykonotopov@gnome.org> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/pcsx2/Manifest1
-rw-r--r--games-emulation/pcsx2/pcsx2-1.6.0_rc.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/games-emulation/pcsx2/Manifest b/games-emulation/pcsx2/Manifest
index d6e6fc1a5393..ec8552bfec1b 100644
--- a/games-emulation/pcsx2/Manifest
+++ b/games-emulation/pcsx2/Manifest
@@ -1 +1,2 @@
DIST pcsx2-1.4.0.tar.gz 15108326 BLAKE2B 6601019f9bd038d8cb3ed5ebd47daa5b645e537d028581c1235f9ab03f59d281639913ef037be3ef380a76bd48ea4f8728b0339fafcd331b4cfa41681dbcabd0 SHA512 87ae8bdebcaf015ba03c23056bcab32b13d6726a6c3f05e62ef54f472114399debfcfcda4208b066519c2d20345a1bb8c55582eb342dccc168f410687f3766fb
+DIST pcsx2-1.6.0_rc.tar.gz 17914747 BLAKE2B e088997a7dc8632070f6bcb70defe0ea226fe250bcefd76ab7499d765ba38e7c249fa4e7048815c173fb2e529ef9cd7e139e03b5a178e5dbcaacab6442bb5517 SHA512 41da55efe0652dc2494c7266375a00f7942f45cfbc2602ab981739102876781c474e54758a9c556f189f7b2e34c81fd1f027cfbc4033fb3b817d63387a9c9db3
diff --git a/games-emulation/pcsx2/pcsx2-1.6.0_rc.ebuild b/games-emulation/pcsx2/pcsx2-1.6.0_rc.ebuild
new file mode 100644
index 000000000000..58e7478a41b5
--- /dev/null
+++ b/games-emulation/pcsx2/pcsx2-1.6.0_rc.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+MY_PV="${PV/_/-}"
+
+inherit cmake multilib toolchain-funcs wxwidgets
+
+DESCRIPTION="A PlayStation 2 emulator"
+HOMEPAGE="https://www.pcsx2.net"
+SRC_URI="https://github.com/PCSX2/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+RDEPEND="
+ app-arch/bzip2[abi_x86_32(-)]
+ app-arch/xz-utils[abi_x86_32(-)]
+ dev-libs/libaio[abi_x86_32(-)]
+ dev-libs/libxml2:2[abi_x86_32(-)]
+ media-libs/alsa-lib[abi_x86_32(-)]
+ media-libs/libpng:=[abi_x86_32(-)]
+ media-libs/libsdl2[abi_x86_32(-),haptic,joystick,sound]
+ media-libs/libsoundtouch[abi_x86_32(-)]
+ media-libs/portaudio[abi_x86_32(-)]
+ net-libs/libpcap[abi_x86_32(-)]
+ sys-libs/zlib[abi_x86_32(-)]
+ virtual/libudev[abi_x86_32(-)]
+ virtual/opengl[abi_x86_32(-)]
+ x11-libs/gtk+:3[abi_x86_32(-)]
+ x11-libs/libICE[abi_x86_32(-)]
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+ >=x11-libs/wxGTK-3.0.4-r301:3.0-gtk3[abi_x86_32(-),X]
+"
+# Ensure no incompatible headers from eselect-opengl are installed, bug #510730
+DEPEND="${RDEPEND}
+ dev-cpp/pngpp
+ dev-cpp/sparsehash
+"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary && $(tc-getCC) == *gcc* ]]; then
+ # -mxsave flag is needed when GCC >= 8.2 is used
+ # https://bugs.gentoo.org/685156
+ if [[ $(gcc-major-version) -gt 8 || $(gcc-major-version) == 8 && $(gcc-minor-version) -ge 2 ]]; then
+ append-flags -mxsave
+ fi
+ fi
+}
+
+src_configure() {
+ multilib_toolchain_setup x86
+
+ # pcsx2 build scripts will force CMAKE_BUILD_TYPE=Devel
+ # if it something other than "Devel|Debug|Release"
+ local CMAKE_BUILD_TYPE="Release"
+
+ if use amd64; then
+ # Passing correct CMAKE_TOOLCHAIN_FILE for amd64
+ # https://github.com/PCSX2/pcsx2/pull/422
+ local MYCMAKEARGS=(-DCMAKE_TOOLCHAIN_FILE=cmake/linux-compiler-i386-multilib.cmake)
+ fi
+
+ local mycmakeargs=(
+ -DARCH_FLAG=
+ -DDISABLE_BUILD_DATE=TRUE
+ -DDISABLE_PCSX2_WRAPPER=TRUE
+ -DEXTRA_PLUGINS=FALSE
+ -DOPTIMIZATION_FLAG=
+ -DPACKAGE_MODE=TRUE
+ -DXDG_STD=TRUE
+
+ -DCMAKE_LIBRARY_PATH="/usr/$(get_libdir)/${PN}"
+ -DDOC_DIR=/usr/share/doc/"${PF}"
+ -DEGL_API=FALSE
+ -DGTK3_API=TRUE
+ -DOPENCL_API=FALSE
+ -DPLUGIN_DIR="/usr/$(get_libdir)/${PN}"
+ # wxGTK must be built against same sdl version
+ -DSDL2_API=TRUE
+ -DUSE_VTUNE=FALSE
+ )
+
+ WX_GTK_VER="3.0-gtk3" setup-wxwidgets
+ cmake_src_configure
+}
+
+src_install() {
+ # Upstream issues:
+ # https://github.com/PCSX2/pcsx2/issues/417
+ # https://github.com/PCSX2/pcsx2/issues/3077
+ QA_EXECSTACK="usr/bin/PCSX2"
+ QA_TEXTRELS="usr/$(get_libdir)/pcsx2/* usr/bin/PCSX2"
+ cmake_src_install
+}